summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-08-01 10:55:22 +0200
committerSlávek Banko <[email protected]>2021-08-01 10:55:22 +0200
commit26d741813467cf71a89df3d7e534a8684d732584 (patch)
tree8f7519b5f90ed31b9d04ebb2ef98de7d60cd6fbf /CMakeLists.txt
parent010f2edd07c9e84bb794642adb07cb41598b10f6 (diff)
downloadkrename-26d741813467cf71a89df3d7e534a8684d732584.tar.gz
krename-26d741813467cf71a89df3d7e534a8684d732584.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16a632c..e329879 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,8 +69,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files