summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2018-12-10 22:53:06 +0100
committerSlávek Banko <[email protected]>2018-12-10 22:53:21 +0100
commit93682fe3b48d5dd14034810144fc0b469534784d (patch)
tree2db479a8b1f4972350f324aef91f8fc4d31e2bde /po/CMakeLists.txt
parente6f57c86d10bfb1e7af7ec36ad2868667649e1d0 (diff)
downloadkrename-93682fe3b48d5dd14034810144fc0b469534784d.tar.gz
krename-93682fe3b48d5dd14034810144fc0b469534784d.zip
Add CMakeL10n rules.
Create translation template. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit e1a137e8599719fd5461aa55ba6fe47ab0ac139e)
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index f5a2e1b..46fba83 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1 +1,6 @@
-tde_create_translation( LANG auto OUTPUT_NAME ${PROJECT_NAME} )
+# build translations if some are already available
+
+file( GLOB _srcs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+if( _srcs )
+ tde_create_translation( LANG auto OUTPUT_NAME ${PROJECT_NAME} )
+endif( )