summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-01-14 13:48:58 +0100
committerMichele Calgaro <[email protected]>2020-01-26 00:51:05 +0900
commitdd79cfcd646b638b99ef1e6e3c833c4976fc95e0 (patch)
tree1edc1fdec78ea78edd83ba46540cbbfd04159256 /CMakeLists.txt
parente010bf5ccc2b72ca8d59e4481ff6e40579f5adf5 (diff)
downloadksensors-dd79cfcd646b638b99ef1e6e3c833c4976fc95e0.tar.gz
ksensors-dd79cfcd646b638b99ef1e6e3c833c4976fc95e0.zip
Drop automake build support.
Add basic cmake build instructions. Delete LEEME, LIESMICH and LISEZMOI files. Delete empty file NEWS. Rework of the FAQ, INSTALL and README files. Add detection for the lm-sensors and math libc libraries. Move the ksensors.desktop file into XDG_APPS_INSTALL_DIR directory, see TDE/tde#26 and bug 2408. Add French description and comments in the ksensors.desktop file. Some cosmetics here and there. Signed-off-by: gregory guy <[email protected]> (cherry picked from commit e383a9d6aecec8ed53d1a0f3ce804f1ce550476f)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a69715e..6aa2a1e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -69,7 +69,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )