summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt16
1 files changed, 7 insertions, 9 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 32ff0f4..f841d12 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,9 +1,13 @@
+add_subdirectory( pics )
+add_subdirectory( sounds )
+
include_directories(
${CMAKE_BINARY_DIR}
${CMAKE_CURRENT_BINARY_DIR}
${CMAKE_CURRENT_SOURCE_DIR}
${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
+ ${SENSORS_INCLUDE_DIRS}
)
link_directories(
@@ -32,8 +36,8 @@ tde_add_executable( ${PROJECT_NAME} AUTOMOC
LINK
tdeui-shared
tdecore-shared
- sensors
- m
+ ${SENSORS_LIBRARIES}
+ ${MATH_LIBC}
DESTINATION ${BIN_INSTALL_DIR}
)
@@ -53,11 +57,5 @@ install(
install(
FILES ${PROJECT_NAME}.desktop
- DESTINATION ${APPS_INSTALL_DIR}/System
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
)
-
-
-##### other directories
-
-add_subdirectory( pics )
-add_subdirectory( sounds )