summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2020-10-01 20:01:09 +0900
committerMichele Calgaro <[email protected]>2020-10-01 20:15:29 +0900
commit4f0abfba52157842c2cd19f832f3475fb8f5eb4d (patch)
tree72fe904c995486a482afd18aeb090bc087138753 /translations/messages/CMakeLists.txt
parent6726e2fbb9c2cfc27bc67e7793863bc036b55944 (diff)
downloadkshowmail-4f0abfba52157842c2cd19f832f3475fb8f5eb4d.tar.gz
kshowmail-4f0abfba52157842c2cd19f832f3475fb8f5eb4d.zip
Copy translation files to new translations folder.
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 54a6036f059620e55df5e574ef8fbf3f3671a158)
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )