summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-05-03 02:39:22 +0200
committerSlávek Banko <[email protected]>2020-05-03 02:39:22 +0200
commit460b0273772f313ff533ba655ccaa11cf7acef5c (patch)
tree9ee16960767f394dd426921f86ae1a710301772d /CMakeLists.txt
parent51efb685369b4126eeb67225b7a775f9bc2ad66d (diff)
downloadksplash-engine-moodin-460b0273772f313ff533ba655ccaa11cf7acef5c.tar.gz
ksplash-engine-moodin-460b0273772f313ff533ba655ccaa11cf7acef5c.zip
Add the ability to translate:
+ Catalog for strings in the plugin. + Desktop file translations. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b1e4eba..0b9fae7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,7 +47,9 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
##### user requested modules
-option( BUILD_ALL "Build all" ON )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_THEMES "Build themes" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -67,6 +69,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
##### write configure files