summaryrefslogtreecommitdiffstats
path: root/icons/pics/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-10-12 15:43:57 +0200
committerSlávek Banko <[email protected]>2020-11-05 18:49:06 +0100
commitf84a48543b2471121d36334e094e0f85f9b9c431 (patch)
tree82d605f1f611a679bce6848d71ddaaf783be9287 /icons/pics/CMakeLists.txt
parent33040db93b91f5ca502dcc682d944fcfe4cd331a (diff)
downloadktechlab-f84a48543b2471121d36334e094e0f85f9b9c431.tar.gz
ktechlab-f84a48543b2471121d36334e094e0f85f9b9c431.zip
Conversion to the cmake building system.
Added man pages taken from the Debian packaging system. Move the ktechlab.desktop file into XDG_APPS_INSTALL_DIR directory, see TDE/tde#26 and bug 2408. Signed-off-by: gregory guy <[email protected]> (cherry picked from commit a9c86866c380e503dd75797b5c2d129bfb622a9e)
Diffstat (limited to 'icons/pics/CMakeLists.txt')
-rw-r--r--icons/pics/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/icons/pics/CMakeLists.txt b/icons/pics/CMakeLists.txt
new file mode 100644
index 0000000..4c8f6f8
--- /dev/null
+++ b/icons/pics/CMakeLists.txt
@@ -0,0 +1,8 @@
+##### icons
+
+file( GLOB _pics RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.png )
+
+install(
+ FILES ${_pics}
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/icons
+)