summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2025-03-10 20:36:49 +0900
committerMichele Calgaro <[email protected]>2025-03-21 14:10:54 +0900
commitbf204e931c605c73d761ec84943bb0cc94d7e7e4 (patch)
treeb11fccbf3b4846f07130d8626e3f40103dd4cbc4 /CMakeLists.txt
parent44ef0bd5fe47a43e47aec5f7981b6c1d728dd9a8 (diff)
downloadktorrent-bf204e931c605c73d761ec84943bb0cc94d7e7e4.tar.gz
ktorrent-bf204e931c605c73d761ec84943bb0cc94d7e7e4.zip
Conversion to cmake building system
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt93
1 files changed, 93 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..97c15eb
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,93 @@
+############################################
+# #
+# Improvements and feedbacks are welcome #
+# #
+# This file is released under GPL >= 3 #
+# #
+############################################
+
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
+
+
+#### general package setup
+
+project( ktorrent )
+
+
+#### include essential cmake modules
+
+include( FindPkgConfig )
+include( CheckFunctionExists )
+include( CheckSymbolExists )
+include( CheckIncludeFile )
+include( CheckLibraryExists )
+include( CheckCSourceCompiles )
+include( CheckCXXSourceCompiles )
+enable_testing()
+
+
+#### include our cmake modules
+
+include( TDEMacros )
+
+
+##### setup install paths
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### optional stuff
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ZEROCONF "Enable zeroconf support" ${WITH_ALL_OPTIONS} )
+option( WITH_SYSTEM_GEOIP "Enable system-wide geoip support" ${WITH_ALL_OPTIONS} )
+option( WITH_BUILTIN_GEOIP "Enable built-in geoip support" OFF )
+option( WITH_BUILTIN_FLAGS "Install built-in flags" ${WITH_BUILTIN_GEOIP} )
+option( WITH_TORRENT_MIMETYPE "Install torrent mime type" OFF )
+option( WITH_MEMLEAK_TRACING "Enable memory leak tracing" OFF )
+option( WITH_PROFILING_SUPPORT "Enable profiling support" OFF )
+
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+
+
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
+##### configure checks
+
+include( ConfigureChecks.cmake )
+
+
+###### global compiler settings
+
+add_definitions( -DHAVE_CONFIG_H )
+
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
+set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )
+
+
+##### directories
+
+add_subdirectory( src )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
+
+##### write configure files
+
+configure_file( config.h.cmake config.h @ONLY )