summaryrefslogtreecommitdiffstats
path: root/src/apps/ktcachecheck/Makefile.am
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2025-03-02 18:37:22 +0900
committerMichele Calgaro <[email protected]>2025-03-06 12:31:12 +0900
commit44ef0bd5fe47a43e47aec5f7981b6c1d728dd9a8 (patch)
tree2b29e921a9bccea53444ed9bbed06a25a5fe20cc /src/apps/ktcachecheck/Makefile.am
parentd1f24dae035c506d945ca13f2be398aa0a4de8cc (diff)
downloadktorrent-44ef0bd5fe47a43e47aec5f7981b6c1d728dd9a8.tar.gz
ktorrent-44ef0bd5fe47a43e47aec5f7981b6c1d728dd9a8.zip
Restructure source files into 'src' subfolderHEADmaster
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'src/apps/ktcachecheck/Makefile.am')
-rw-r--r--src/apps/ktcachecheck/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/apps/ktcachecheck/Makefile.am b/src/apps/ktcachecheck/Makefile.am
new file mode 100644
index 0000000..a9f5d3e
--- /dev/null
+++ b/src/apps/ktcachecheck/Makefile.am
@@ -0,0 +1,12 @@
+INCLUDES = -I$(srcdir)/../../libktorrent $(all_includes)
+METASOURCES = AUTO
+
+bin_PROGRAMS = ktcachecheck
+
+ktcachecheck_SOURCES = cachecheck.cpp cachechecker.cpp singlecachechecker.cpp \
+ multicachechecker.cpp
+ktcachecheck_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+ktcachecheck_LDADD = $(LIB_TDEPARTS) ../../libktorrent/libktorrent.la \
+ $(LIB_TDEFILE) $(LIB_TDEIO)
+noinst_HEADERS = cachechecker.h singlecachechecker.h multicachechecker.h
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) $(USE_RTTI)