summaryrefslogtreecommitdiffstats
path: root/src/plugins/rssfeed/Makefile.am
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2025-03-02 18:37:22 +0900
committerMichele Calgaro <[email protected]>2025-03-06 12:31:12 +0900
commit44ef0bd5fe47a43e47aec5f7981b6c1d728dd9a8 (patch)
tree2b29e921a9bccea53444ed9bbed06a25a5fe20cc /src/plugins/rssfeed/Makefile.am
parentd1f24dae035c506d945ca13f2be398aa0a4de8cc (diff)
downloadktorrent-master.tar.gz
ktorrent-master.zip
Restructure source files into 'src' subfolderHEADmaster
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'src/plugins/rssfeed/Makefile.am')
-rw-r--r--src/plugins/rssfeed/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/plugins/rssfeed/Makefile.am b/src/plugins/rssfeed/Makefile.am
new file mode 100644
index 0000000..e5fa2ed
--- /dev/null
+++ b/src/plugins/rssfeed/Makefile.am
@@ -0,0 +1,30 @@
+INCLUDES = -I$(srcdir)/../../libktorrent $(all_includes)
+METASOURCES = AUTO
+kde_module_LTLIBRARIES = ktrssfeedplugin.la
+
+
+# LD flags for the plugin
+# -module says: this is a module, i.e. something you're going to dlopen
+# so e.g. it has no version number like a normal shared lib would have.
+ktrssfeedplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+# rc file containing the GUI for the plugin
+# pluginsdir = $(kde_datadir)/ktrssfeedplugin
+# plugins_DATA = ktrssfeedpluginui.rc
+
+# Install the desktop file needed to detect the plugin
+
+rcdir = $(kde_datadir)/ktorrent
+
+kde_kcfg_DATA = ktrssfeedplugin.kcfg
+kde_services_DATA = ktrssfeedplugin.desktop
+
+noinst_HEADERS = rssfeedplugin.h rssfeedmanager.h rssfeed.h rssfilter.h \
+ rssarticle.h rsslinkdownloader.h
+ktrssfeedplugin_la_SOURCES = rssfeedplugin.cpp rssfeedmanager.cpp \
+ rssfeedwidget.ui rssfeed.cpp rssfilter.cpp rssarticle.cpp rsslinkdownloader.cpp
+ktrssfeedplugin_la_LIBADD = $(LIB_TDEIO) $(LIB_TQT) rss/librsslocal.la \
+ ../../libktorrent/libktorrent.la $(LIB_TDECORE) $(LIB_TDEUI) $(LIB_TDEHTML) $(LIB_TDEPARTS)
+
+SUBDIRS = rss
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) $(USE_RTTI)