summaryrefslogtreecommitdiffstats
path: root/src/plugins/rssfeed/rss/Makefile.am
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2025-03-02 18:37:22 +0900
committerMichele Calgaro <[email protected]>2025-03-06 12:31:12 +0900
commit44ef0bd5fe47a43e47aec5f7981b6c1d728dd9a8 (patch)
tree2b29e921a9bccea53444ed9bbed06a25a5fe20cc /src/plugins/rssfeed/rss/Makefile.am
parentd1f24dae035c506d945ca13f2be398aa0a4de8cc (diff)
downloadktorrent-44ef0bd5fe47a43e47aec5f7981b6c1d728dd9a8.tar.gz
ktorrent-44ef0bd5fe47a43e47aec5f7981b6c1d728dd9a8.zip
Restructure source files into 'src' subfolderHEADmaster
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'src/plugins/rssfeed/rss/Makefile.am')
-rw-r--r--src/plugins/rssfeed/rss/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/plugins/rssfeed/rss/Makefile.am b/src/plugins/rssfeed/rss/Makefile.am
new file mode 100644
index 0000000..8053f92
--- /dev/null
+++ b/src/plugins/rssfeed/rss/Makefile.am
@@ -0,0 +1,20 @@
+INCLUDES = \
+ -I$(top_srcdir)/src \
+ $(all_includes)
+
+noinst_LTLIBRARIES = \
+ librsslocal.la
+
+noinst_HEADERS = article.h document.h global.h image.h textinput.h \
+ loader.h librss.h
+
+librsslocal_la_SOURCES = article.cpp document.cpp image.cpp textinput.cpp \
+ tools_p.cpp loader.cpp
+
+librsslocal_la_METASOURCES = AUTO
+
+check_PROGRAMS = testlibrss
+testlibrss_SOURCES = testlibrss.cpp
+testlibrss_LDFLAGS = $(all_libraries)
+testlibrss_LDADD = librsslocal.la $(LIB_TDEIO)
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) $(USE_RTTI)