summaryrefslogtreecommitdiffstats
path: root/src/utests/Makefile.am
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2025-03-02 18:37:22 +0900
committerMichele Calgaro <[email protected]>2025-03-06 12:31:12 +0900
commit44ef0bd5fe47a43e47aec5f7981b6c1d728dd9a8 (patch)
tree2b29e921a9bccea53444ed9bbed06a25a5fe20cc /src/utests/Makefile.am
parentd1f24dae035c506d945ca13f2be398aa0a4de8cc (diff)
downloadktorrent-master.tar.gz
ktorrent-master.zip
Restructure source files into 'src' subfolderHEADmaster
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'src/utests/Makefile.am')
-rw-r--r--src/utests/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/utests/Makefile.am b/src/utests/Makefile.am
new file mode 100644
index 0000000..78de5ad
--- /dev/null
+++ b/src/utests/Makefile.am
@@ -0,0 +1,12 @@
+INCLUDES = -I$(srcdir)/../libktorrent -I$(srcdir)/.. $(all_includes)
+METASOURCES = AUTO
+noinst_HEADERS = unittest.h testrunner.h upnpparsedescriptiontest.h \
+ upnpparseresponsetest.h dhtmsgparsetest.h biginttest.h rc4test.h difflehellmantest.h
+bin_PROGRAMS = ktutester
+ktutester_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+ktutester_SOURCES = unittest.cpp testrunner.cpp main.cpp \
+ upnpparsedescriptiontest.cpp upnpparseresponsetest.cpp dhtmsgparsetest.cpp biginttest.cpp \
+ rc4test.cpp difflehellmantest.cpp
+ktutester_LDADD = ../plugins/upnp/libktupnp.la \
+ ../libktorrent/libktorrent.la
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) $(USE_RTTI)