summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-05-03 10:23:34 +0200
committerSlávek Banko <[email protected]>2020-05-03 10:23:51 +0200
commit0f3101ef4c8c3d18d500317f06994d12792f15e4 (patch)
tree88c55979bbfb229faed6ccb586fbcbe6ab5fe3e2 /doc/CMakeLists.txt
parent44892df5231ca47cd37f9e5cb17781995cfa08c1 (diff)
downloadkvkbd-0f3101ef4c8c3d18d500317f06994d12792f15e4.tar.gz
kvkbd-0f3101ef4c8c3d18d500317f06994d12792f15e4.zip
Move translations to a new directory layout.
Add support for LINGUAS for listing translations to install. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 4a8dc3c4bc293d0b40adc6f138f0da0dc75c7a71)
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index c938175..70d6348 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -1 +1,14 @@
-add_subdirectory( en )
+file( GLOB _dirs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} * )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _dir ${_dirs} )
+ if( IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/${_dir} AND
+ EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${_dir}/CMakeLists.txt )
+ if( "${_dir}" STREQUAL "en" OR
+ "${_dir}" STREQUAL "man" OR
+ "${_linguas}" MATCHES "^;*$" OR
+ ";${_linguas};" MATCHES ";${_dir};" )
+ add_subdirectory( ${_dir} )
+ endif( )
+ endif()
+endforeach()