summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-02-12 14:02:24 +0100
committerMichele Calgaro <[email protected]>2020-02-12 23:24:18 +0900
commitc8f152ab7e637d0bf13effdb09d7a095d171948f (patch)
tree84e399f9eb6d0c966ff79e44e004564b7fd19477 /src/CMakeLists.txt
parent6600b1e14df45104c08f0df8f3a86bd3ea2c91f0 (diff)
downloadkvkbd-c8f152ab7e637d0bf13effdb09d7a095d171948f.tar.gz
kvkbd-c8f152ab7e637d0bf13effdb09d7a095d171948f.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty file NEWS, TODO and ChangeLog. Delete empty folder "templates". Add detection for the XTest library. Move the kvkbd.desktop file into XDG_APPS_INSTALL_DIR directory, see TDE/tde#26 . Some cosmetics. Signed-off-by: gregory guy <[email protected]> (cherry picked from commit 92482b762101fc6e18740ba34ffb688e77ea8cfa)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 82c1669..6df8e96 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -4,6 +4,8 @@ include_directories(
${CMAKE_CURRENT_SOURCE_DIR}
${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
+ ${X11_INCLUDE_DIR}
+ ${X11_XTest_INCLUDE_PATH}
)
link_directories(
@@ -27,7 +29,7 @@ tde_add_executable( ${PROJECT_NAME} AUTOMOC
tdecore-shared
tdeui-shared
tdeio-shared
- Xtst
+ ${X11_XTest_LIB}
DESTINATION ${BIN_INSTALL_DIR}
)
@@ -47,5 +49,5 @@ install(
install(
FILES ${PROJECT_NAME}.desktop
- DESTINATION ${APPS_INSTALL_DIR}/Utilities
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
)