summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..965d274
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,38 @@
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = DragWidget.h KeyClip.h MainWidget.h VButton.h numpadvbutton.h
+
+# let automoc handle all of the meta source files (moc)
+
+messages: rc.cpp
+ $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kvkbd.pot
+
+KDE_ICON = AUTO
+
+#########################################################################
+# APPLICATION SECTION
+#########################################################################
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = kvkbd
+
+# the application source, library search path, and link libraries
+kvkbd_SOURCES = DragWidget.cpp KeyClip.cpp MainWidget.cpp VButton.cpp main.cpp \
+ numpadvbutton.cpp resizabledragwidget.cpp resizabledragwidget.h
+kvkbd_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+kvkbd_LDADD = -lXtst $(LIB_KDEUI)
+
+# this is where the desktop file will go
+shelldesktopdir = $(kde_appsdir)/Utilities
+shelldesktop_DATA = kvkbd.desktop
+
+# this is where the shell's XML-GUI resource file goes
+shellrcdir = $(kde_datadir)/kvkbd
+
+picsdir = $(kde_datadir)/kvkbd/pics
+picsdir_DATA = dock.png tray.png
+picsdirdir = $(kde_datadir)/kvkbd/pics
+METASOURCES = AUTO