summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-03-13 16:31:34 +0100
committerSlávek Banko <[email protected]>2019-03-31 03:59:01 +0200
commit53290bd3fd60f540d82d6eece40af1d9f2cb8fa5 (patch)
tree9d0af1e1fe71e07f97ddbe1798f01423867b7492 /po/CMakeLists.txt
parent5c37bbb4ad9e00e6a8358608722a141bc14b80d7 (diff)
downloadlibkipi-53290bd3fd60f540d82d6eece40af1d9f2cb8fa5.tar.gz
libkipi-53290bd3fd60f540d82d6eece40af1d9f2cb8fa5.zip
conversion to the cmake building system
Signed-off-by: gregory guy <[email protected]> (cherry picked from commit 4dfb812575ade9e6dbeb10389c58588238c316d8)
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..e3b5278
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,7 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${PROJECT_NAME}.po )
+
+foreach( _po ${po_files} )
+ string( REPLACE "/" ";" _path "${_po}" )
+ list( GET _path 0 _lang )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )