summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2023-05-27 18:38:14 +0900
committerMichele Calgaro <[email protected]>2023-09-21 20:02:00 +0900
commitf378f80d41bd9f85f5473d1af5920d00377faab3 (patch)
tree47c83ff3040f2f5ccc9ce8f9219f0859882aaf09 /doc/CMakeLists.txt
parent2a7760d9b697a6845c3f0256edc0aaef3a202295 (diff)
downloadlibksquirrel-f378f80d41bd9f85f5473d1af5920d00377faab3.tar.gz
libksquirrel-f378f80d41bd9f85f5473d1af5920d00377faab3.zip
Conversion to cmake building system
Signed-off-by: Michele Calgaro <[email protected]> Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit af121719c99a99fc3444d181777a6177f0d59dba)
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
new file mode 100644
index 0000000..c5ecf8c
--- /dev/null
+++ b/doc/CMakeLists.txt
@@ -0,0 +1,17 @@
+install(
+ DIRECTORY html/
+ DESTINATION ${SHARE_INSTALL_PREFIX}/doc/ksquirrel-libs/${LIBKSQUIRREL_VERSION_STRING}
+ PATTERN "Makefile.am" EXCLUDE
+)
+
+install(
+ DIRECTORY man/
+ DESTINATION ${MAN_INSTALL_DIR}/man1
+ PATTERN "Makefile.am" EXCLUDE
+)
+
+install(
+ DIRECTORY sources/
+ DESTINATION ${SHARE_INSTALL_PREFIX}/doc/ksquirrel-libs/${LIBKSQUIRREL_VERSION_STRING}/sources
+ PATTERN "sources/Makefile.am" EXCLUDE
+)