summaryrefslogtreecommitdiffstats
path: root/kernel/kls_openexr/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2023-05-27 18:38:14 +0900
committerMichele Calgaro <[email protected]>2023-09-21 20:02:00 +0900
commitf378f80d41bd9f85f5473d1af5920d00377faab3 (patch)
tree47c83ff3040f2f5ccc9ce8f9219f0859882aaf09 /kernel/kls_openexr/CMakeLists.txt
parent2a7760d9b697a6845c3f0256edc0aaef3a202295 (diff)
downloadlibksquirrel-f378f80d41bd9f85f5473d1af5920d00377faab3.tar.gz
libksquirrel-f378f80d41bd9f85f5473d1af5920d00377faab3.zip
Conversion to cmake building system
Signed-off-by: Michele Calgaro <[email protected]> Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit af121719c99a99fc3444d181777a6177f0d59dba)
Diffstat (limited to 'kernel/kls_openexr/CMakeLists.txt')
-rw-r--r--kernel/kls_openexr/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/kernel/kls_openexr/CMakeLists.txt b/kernel/kls_openexr/CMakeLists.txt
new file mode 100644
index 0000000..d1f0cc5
--- /dev/null
+++ b/kernel/kls_openexr/CMakeLists.txt
@@ -0,0 +1,16 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/kernel/include
+ ${CMAKE_BINARY_DIR}
+ ${OPENEXR_INCLUDE_DIRS}
+)
+
+
+##### codecs
+
+tde_add_library( kls_openexr SHARED AUTOMOC
+ SOURCES fmt_codec_openexr.cpp
+ LINK ksquirrel-libs-shared ${OPENEXR_LIBRARIES}
+ VERSION 0.8.0
+ DESTINATION ${LIB_INSTALL_DIR}/ksquirrel-libs
+)