summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-01-12 17:06:36 +0100
committerSlávek Banko <[email protected]>2019-02-04 22:22:01 +0100
commit90487b6cffc8b8404dd06d280dbdfa3264644823 (patch)
treee62344be713297aefd0f755a937795fa2c08db1e /src/CMakeLists.txt
parent7f2250b87f35e09268733519aa2c4213c609bd1b (diff)
downloadlibtdeldap-90487b6cffc8b8404dd06d280dbdfa3264644823.tar.gz
libtdeldap-90487b6cffc8b8404dd06d280dbdfa3264644823.zip
conversion to the cmake building system
Signed-off-by: gregory guy <[email protected]> (cherry picked from commit 6d8d495faf0a8670d1657ec4dc0fb84f3e3d249a)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..09658b9
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,43 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}/tde
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${KRB5_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### tdeldap (shared)
+
+tde_add_library( tdeldap SHARED AUTOMOC
+
+ SOURCES
+ libtdeldap.cpp
+ ldaplogindlgbase.ui
+ ldaplogindlg.cpp
+ ldappasswddlg.cpp
+ LINK
+ tdeui-shared
+ tdecore-shared
+ tdeio-shared
+ tdesu
+ lber
+ ldap
+
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+##### headers
+
+install(
+ FILES ldappasswddlg.h libtdeldap.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}
+)