summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMateus Cesar Groess <[email protected]>2012-02-11 19:34:22 +0100
committerChristian Beier <[email protected]>2012-02-11 19:34:22 +0100
commit1078e8a8b050b5b4ebbcb011750f5dd2d8eacc37 (patch)
treec77de6a7641e39324743ca4c26fb402a52626912 /configure.ac
parent4ed29e0a36e043ddf53f572b84004c7fe4d40b1d (diff)
downloadlibtdevnc-1078e8a8b050b5b4ebbcb011750f5dd2d8eacc37.tar.gz
libtdevnc-1078e8a8b050b5b4ebbcb011750f5dd2d8eacc37.zip
Here is a port of SDLvncviewer to GTK+2.
I think it may encourage people to implement more features for the viewer, because a GTK GUI seems to be easier to implement than a SDL one (and it is more integrated with the major Linux Desktops out there). Signed-off-by: Christian Beier <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31aa1f2..c5578fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -740,6 +740,10 @@ AC_SUBST(SDL_CFLAGS)
AC_SUBST(SDL_LIBS)
+# Check for GTK+. if present, build the GTK+ vnc viewer example
+PKG_CHECK_MODULES([GTK], [gtk+-2.0])
+AM_CONDITIONAL(HAVE_LIBGTK, test ! -z "$GTK_LIBS")
+
AC_CANONICAL_HOST
MINGW=`echo $host_os | grep mingw32 2>/dev/null`
AM_CONDITIONAL(MINGW, test ! -z "$MINGW" )