summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoel Martin <[email protected]>2011-08-16 14:02:31 +0200
committerJohannes Schindelin <[email protected]>2011-08-17 12:41:23 +0200
commit6fac22a74b5020387a6961e4cc197b5fa4743f96 (patch)
tree9eb15702fbeed2f15fe2de17b54ac92544582509 /configure.ac
parent353b35e86aa7d51d767f4ff66e1179105bbee205 (diff)
downloadlibtdevnc-6fac22a74b5020387a6961e4cc197b5fa4743f96.tar.gz
libtdevnc-6fac22a74b5020387a6961e4cc197b5fa4743f96.zip
websockets: Initial WebSockets support.
Has a bug: WebSocket client disconnects are not detected. rfbSendFramebufferUpdate is doing a MSG_PEEK recv to determine if enough data is available which prevents a disconnect from being detected. Otherwise it's working pretty well. [jes: moved added struct members to the end for binary compatibility with previous LibVNCServer versions, removed an unused variable] Signed-off-by: Johannes Schindelin <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 280ea58..029a600 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,14 @@ AC_ARG_WITH(tightvnc-filetransfer,
, [ with_tightvnc_filetransfer=yes ])
# AC_DEFINE moved to after libpthread check.
+# WebSockets support
+AC_CHECK_LIB(resolv, __b64_ntop, HAVE_B64="true", HAVE_B64="false")
+AH_TEMPLATE(WITH_WEBSOCKETS, [Disable WebSockets support])
+AC_ARG_WITH(websockets,
+ [ --without-websockets disable WebSockets support],
+ , [ with_websockets=yes ])
+# AC_DEFINE moved to after libresolve check.
+
AH_TEMPLATE(ALLOW24BPP, [Enable 24 bit per pixel in native framebuffer])
AC_ARG_WITH(24bpp,
[ --without-24bpp disable 24 bpp framebuffers],
@@ -301,6 +309,7 @@ elif test "x$uname_s" = "xDarwin"; then
fi
+
AH_TEMPLATE(HAVE_LIBCRYPT, [libcrypt library present])
AC_ARG_WITH(crypt,
[ --without-crypt disable support for libcrypt],,)
@@ -706,6 +715,16 @@ if test "x$with_tightvnc_filetransfer" = "xyes"; then
fi
AM_CONDITIONAL(WITH_TIGHTVNC_FILETRANSFER, test "$with_tightvnc_filetransfer" = "yes")
+# websockets implemented using base64 from resolve
+if test "x$HAVE_B64" != "xtrue"; then
+ with_websockets=""
+fi
+if test "x$with_websockets" = "xyes"; then
+ LIBS="$LIBS -lresolv"
+ AC_DEFINE(WITH_WEBSOCKETS)
+fi
+AM_CONDITIONAL(WITH_WEBSOCKETS, test "$with_websockets" = "yes")
+
AM_CONDITIONAL(HAVE_LIBZ, test ! -z "$HAVE_ZLIB_H")
AM_CONDITIONAL(HAVE_LIBJPEG, test ! -z "$HAVE_JPEGLIB_H")
AM_CONDITIONAL(HAVE_LIBPNG, test ! -z "$HAVE_PNGLIB_H")