summaryrefslogtreecommitdiffstats
path: root/libvncclient/Makefile.am
diff options
context:
space:
mode:
authorChristian Beier <[email protected]>2012-04-14 21:16:09 +0200
committerChristian Beier <[email protected]>2012-04-14 21:16:09 +0200
commit5e9da5a2f8317b58fd825bfd8f8083345ba59719 (patch)
tree914eaa8676122e0ad62e7a169b74fa0489b25ef2 /libvncclient/Makefile.am
parent98f4037785246f77e544bab9196f076fe310be16 (diff)
downloadlibtdevnc-5e9da5a2f8317b58fd825bfd8f8083345ba59719.tar.gz
libtdevnc-5e9da5a2f8317b58fd825bfd8f8083345ba59719.zip
Add the OpenSSL libvncclient TLS version to the build system.
Diffstat (limited to 'libvncclient/Makefile.am')
-rw-r--r--libvncclient/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/libvncclient/Makefile.am b/libvncclient/Makefile.am
index 5dec749..502b73d 100644
--- a/libvncclient/Makefile.am
+++ b/libvncclient/Makefile.am
@@ -1,6 +1,20 @@
INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/common
-libvncclient_la_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c ../common/minilzo.c tls.c
+if HAVE_GNUTLS
+TLSSRCS = tls_gnutls.c
+TLSLIBS = @GNUTLS_LIBS@
+else
+if HAVE_LIBSSL
+TLSSRCS = tls_openssl.c
+TLSLIBS = @SSL_LIBS@ @CRYPT_LIBS@
+else
+TLSSRCS = tls_none.c
+endif
+endif
+
+
+libvncclient_la_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c ../common/minilzo.c $(TLSSRCS)
+libvncclient_la_LIBADD=$(TLSLIBS)
noinst_HEADERS=../common/lzodefs.h ../common/lzoconf.h ../common/minilzo.h tls.h