summaryrefslogtreecommitdiffstats
path: root/x11vnc/Makefile.am
diff options
context:
space:
mode:
authorrunge <runge>2007-02-12 23:44:39 +0000
committerrunge <runge>2007-02-12 23:44:39 +0000
commit241f3ed566d34bf5b6c67ebebcc00727134d93b2 (patch)
treee42ddc70dc6a50503a2e22aef238c7a1fde7fb43 /x11vnc/Makefile.am
parent0016cd4280ee9a0d088454a508a9c7f6bde33f62 (diff)
downloadlibtdevnc-241f3ed566d34bf5b6c67ebebcc00727134d93b2.tar.gz
libtdevnc-241f3ed566d34bf5b6c67ebebcc00727134d93b2.zip
x11vnc: add avahi (aka mDNS/Zeroconf/Bonjour...) support thanks to Diego Petteno. add -find -create
Diffstat (limited to 'x11vnc/Makefile.am')
-rw-r--r--x11vnc/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/x11vnc/Makefile.am b/x11vnc/Makefile.am
index c3b7f1a..bd04821 100644
--- a/x11vnc/Makefile.am
+++ b/x11vnc/Makefile.am
@@ -17,11 +17,12 @@ LD_CYGIPC=-lcygipc
endif
bin_PROGRAMS=x11vnc
-x11vnc_SOURCES = 8to24.c cleanup.c connections.c cursor.c gui.c help.c inet.c keyboard.c linuxfb.c macosx.c macosxCG.c macosxCGP.c macosxCGS.c options.c pm.c pointer.c rates.c remote.c scan.c screen.c selection.c solid.c sslcmds.c sslhelper.c uinput.c unixpw.c user.c userinput.c util.c v4l.c win_utils.c x11vnc.c x11vnc_defs.c xdamage.c xevents.c xinerama.c xkb_bell.c xrandr.c xrecord.c xwrappers.c 8to24.h allowed_input_t.h blackout_t.h cleanup.h connections.h cursor.h enums.h gui.h help.h inet.h keyboard.h linuxfb.h macosx.h macosxCG.h macosxCGP.h macosxCGS.h nox11.h nox11_funcs.h options.h params.h pm.h pointer.h rates.h remote.h scan.h screen.h scrollevent_t.h selection.h solid.h sslcmds.h sslhelper.h ssltools.h tkx11vnc.h uinput.h unixpw.h user.h userinput.h util.h v4l.h win_utils.h winattr_t.h x11vnc.h xdamage.h xevents.h xinerama.h xkb_bell.h xrandr.h xrecord.h xwrappers.h
+x11vnc_SOURCES = 8to24.c avahi.c cleanup.c connections.c cursor.c gui.c help.c inet.c keyboard.c linuxfb.c macosx.c macosxCG.c macosxCGP.c macosxCGS.c options.c pm.c pointer.c rates.c remote.c scan.c screen.c selection.c solid.c sslcmds.c sslhelper.c uinput.c unixpw.c user.c userinput.c util.c v4l.c win_utils.c x11vnc.c x11vnc_defs.c xdamage.c xevents.c xinerama.c xkb_bell.c xrandr.c xrecord.c xwrappers.c 8to24.h allowed_input_t.h avahi.h blackout_t.h cleanup.h connections.h cursor.h enums.h gui.h help.h inet.h keyboard.h linuxfb.h macosx.h macosxCG.h macosxCGP.h macosxCGS.h nox11.h nox11_funcs.h options.h params.h pm.h pointer.h rates.h remote.h scan.h screen.h scrollevent_t.h selection.h solid.h sslcmds.h sslhelper.h ssltools.h tkx11vnc.h uinput.h unixpw.h user.h userinput.h util.h v4l.h win_utils.h winattr_t.h x11vnc.h xdamage.h xevents.h xinerama.h xkb_bell.h xrandr.h xrecord.h xwrappers.h
if HAVE_X
-INCLUDES=@X_CFLAGS@
-x11vnc_LDADD=$(LDADD) @SSL_LIBS@ @CRYPT_LIBS@ @X_LIBS@ $(LD_CYGIPC)
+INCLUDES=@X_CFLAGS@ @AVAHI_CFLAGS@
+x11vnc_LDADD=$(LDADD) @SSL_LIBS@ @CRYPT_LIBS@ @X_LIBS@ @AVAHI_LIBS@ $(LD_CYGIPC)
else
-x11vnc_LDADD=$(LDADD) @SSL_LIBS@ @CRYPT_LIBS@ $(LD_CYGIPC)
+INCLUDES=@AVAHI_CFLAGS@
+x11vnc_LDADD=$(LDADD) @SSL_LIBS@ @CRYPT_LIBS@ @AVAHI_LIBS@ $(LD_CYGIPC)
endif