summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-03-15 16:04:21 +0100
committerMichele Calgaro <[email protected]>2020-03-16 12:34:55 +0900
commit8abac42d8092801f3f19e957d5577ed1910086be (patch)
tree63a0c2400608da181171ff0d504c50970982dce9 /CMakeLists.txt
parent049b177da195f76a7fc3d351c8d6cd2d1060ebd9 (diff)
downloadmplayerthumbs-8abac42d8092801f3f19e957d5577ed1910086be.tar.gz
mplayerthumbs-8abac42d8092801f3f19e957d5577ed1910086be.zip
Drop automake build support.
Delete empty file TODO. Add basic cmake build instructions. Rewrite of the README file. Some cosmetics. Signed-off-by: gregory guy <[email protected]> (cherry picked from commit f6ab2e36b3600d63a29216332e073922c27878cd)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 875eecf..4fc9e26 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,16 +41,16 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
-option( WITH_STRIPS_SUPPORT "Strips over thumbnails" ${WITH_ALL_OPTIONS} )
+option( WITH_STRIPS_SUPPORT "Strips over thumbnails" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -70,8 +70,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
##### write configure files