summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..4af25eb
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+SUBDIRS = . mplayerthumbsconfig
+
+kde_module_LTLIBRARIES = videopreview.la
+
+videopreview_la_SOURCES = videopreview.cpp mplayerthumbs.kcfgc
+videopreview_la_LDFLAGS = -avoid-version -module $(all_libraries) $(KDE_PLUGIN)
+
+protocoldir = $(kde_servicesdir)
+
+messages: rc.cpp
+ $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/videopreview.pot
+protocol_DATA = videopreview.desktop
+videopreview_la_LIBADD = $(LIB_KDECORE)
+
+videothumbnail_DATA = sprocket-small.png sprocket-medium.png sprocket-large.png
+videothumbnaildir = $(kde_datadir)/videothumbnail
+kde_kcfg_DATA = mplayerthumbs.kcfg
+