summaryrefslogtreecommitdiffstats
path: root/src/tools/boost/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-05-07 18:59:54 +0900
committerMichele Calgaro <[email protected]>2024-05-10 10:25:20 +0900
commitdc5b11fc7d45bfeabd0866b8821fefbfc7fd1209 (patch)
tree5774d9f9cb72172ba61ded3344e43577f9baf227 /src/tools/boost/gui/CMakeLists.txt
parentd5d77862d18d9246d246969afc869713877f80fc (diff)
downloadpiklab-dc5b11fc7d45bfeabd0866b8821fefbfc7fd1209.tar.gz
piklab-dc5b11fc7d45bfeabd0866b8821fefbfc7fd1209.zip
CMake conversion
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 199d48de5c43ab5da32fdfe2006f9d89bd4b6d17)
Diffstat (limited to 'src/tools/boost/gui/CMakeLists.txt')
-rw-r--r--src/tools/boost/gui/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/tools/boost/gui/CMakeLists.txt b/src/tools/boost/gui/CMakeLists.txt
new file mode 100644
index 0000000..21ea565
--- /dev/null
+++ b/src/tools/boost/gui/CMakeLists.txt
@@ -0,0 +1,9 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+##### libboostui (static)
+
+tde_add_library( boostui STATIC_PIC AUTOMOC
+ SOURCES boost_ui.cpp
+)