summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2021-12-09 17:02:13 +0900
committerMichele Calgaro <[email protected]>2021-12-09 17:02:13 +0900
commit855818127b02c367fb187e67b9bb9b229b916304 (patch)
treec353d9b96b0135baf7f7a553c59926f2e5866a31 /examples/CMakeLists.txt
parent7d1585c071206dd8460ed624eff764de5464dde7 (diff)
downloadpolkit-tqt-855818127b02c367fb187e67b9bb9b229b916304.tar.gz
polkit-tqt-855818127b02c367fb187e67b9bb9b229b916304.zip
Converted agent example code.
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index d3b3a8407..8cb8e8c5b 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -31,6 +31,7 @@ tde_setup_dbus( dbus-1-tqt )
set( POLKIT_TQT_EXAMPLE "${DATA_INSTALL_DIR}/polkit-tqt/examples/" )
+
##### install examples runtime config ###########################
configure_file( org.tqt.policykit.examples.service.cmake org.tqt.policykit.examples.service @ONLY )
@@ -51,6 +52,16 @@ install(
)
+##### install icons ###########################
+
+add_subdirectory( icons )
+
+
+##### adent directory ########################
+
+add_subdirectory( agent )
+
+
##### install examples source code ###########################
install(
@@ -78,11 +89,6 @@ install(
)
-##### install icons ###########################
-
-add_subdirectory( icons )
-
-
##### example executables #########################
tde_add_executable( polkit-tqt-example AUTOMOC