summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2022-01-03 17:55:46 +0100
committerSlávek Banko <[email protected]>2022-01-04 04:06:38 +0100
commit2971f209dbecd56266de42030d226b9085c6bf63 (patch)
treedadecfc99544e994f11c55a70e9957ae67d0e788 /tests/CMakeLists.txt
parent27ea6ede3cc480e4680fcc56b29df6ea824f7877 (diff)
downloadpolkit-tqt-2971f209dbecd56266de42030d226b9085c6bf63.tar.gz
polkit-tqt-2971f209dbecd56266de42030d226b9085c6bf63.zip
CMake rules adjustments:
+ Use the usual TDESetupPaths macros. + Install libraries according to multi-arch rules. + Use `install( DIRECTORY ... )` for headers in CXX style. + Remove linking unused variables ${..._MOCS}. + Remove linking for indirectly used libraries. + Use private linking for exported CMake targets. + Add the installation of exported CMake targets. + Use keyword TEST for tde_add_check_executable. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 92a8543d0..638cacc65 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -22,8 +22,6 @@ include_directories(
)
set( link-polkit-tqt-test
- ${TQT_LIBRARIES}
- polkit-tqt-core-shared
polkit-tqt-gui-shared
polkit-tqt-agent-shared
)
@@ -57,9 +55,8 @@ foreach( _test_name ${_test_auto_executables} )
tde_add_check_executable( ${_test_name}
SOURCES ${_test_name}.cpp AUTOMOC
LINK ${link-polkit-tqt-test}
+ TEST
)
-
- add_test( ${_test_name} ${_test_name} )
endforeach( )
foreach( _test_name ${_test_manual_executables} )
@@ -68,4 +65,3 @@ foreach( _test_name ${_test_manual_executables} )
LINK ${link-polkit-tqt-test}
)
endforeach( )
-