summaryrefslogtreecommitdiffstats
path: root/app_templates/kdeutility/setup.py
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-03-01 18:16:46 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-03-01 18:16:46 +0000
commita7af74e75730559f7f9661e449eb269e356d9907 (patch)
tree72026b40b3a513aa21d630fb09ae10edab7f9e18 /app_templates/kdeutility/setup.py
downloadpytdeextensions-a7af74e75730559f7f9661e449eb269e356d9907.tar.gz
pytdeextensions-a7af74e75730559f7f9661e449eb269e356d9907.zip
Added KDE3 version of pykdeextensions
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/libraries/pykdeextensions@1097589 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'app_templates/kdeutility/setup.py')
-rwxr-xr-xapp_templates/kdeutility/setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/app_templates/kdeutility/setup.py b/app_templates/kdeutility/setup.py
new file mode 100755
index 0000000..ff51c10
--- /dev/null
+++ b/app_templates/kdeutility/setup.py
@@ -0,0 +1,31 @@
+#!/usr/bin/python
+###########################################################################
+# setup - description #
+# ------------------------------ #
+# begin : Fri Jun 27 2005 #
+# copyright : (C) 2005 by AUTHOR #
+# email : [email protected] #
+# #
+###########################################################################
+# #
+# This program is free software; you can redistribute it and/or modify #
+# it under the terms of the GNU General Public License as published by #
+# the Free Software Foundation; either version 2 of the License, or #
+# (at your option) any later version. #
+# #
+###########################################################################
+
+import kdedistutils
+
+kdedistutils.setup(name="kdeutility",
+ version="0.1.0",
+ author="AUTHOR",
+ author_email="[email protected]",
+ url="http://www.TESTAPP.com/",
+ min_kde_version = "3.0.0",
+ min_qt_version = "3.0.0",
+ license = "GPL",
+ application_data = ['src/kdeutility.py','src/KDEUtilityDialogUI.ui'],
+ executable_links = [('kdeutility','kdeutility.py')],
+ docbooks = [ ('doc/en','en') ],
+ i18n = ('po',['src']) )