summaryrefslogtreecommitdiffstats
path: root/app_templates/tdeioslave/setup.py
diff options
context:
space:
mode:
authorTimothy Pearson <[email protected]>2013-01-27 00:59:30 -0600
committerTimothy Pearson <[email protected]>2013-01-27 00:59:30 -0600
commitc82fea08078a724716c673258d296e240c517368 (patch)
treeb7f1a6eb07dc87ecac369edf100db6fe48e5e758 /app_templates/tdeioslave/setup.py
parentc43637b57fccc8d056ce53af8b41a3f9e79d6c38 (diff)
downloadpytdeextensions-c82fea08078a724716c673258d296e240c517368.tar.gz
pytdeextensions-c82fea08078a724716c673258d296e240c517368.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'app_templates/tdeioslave/setup.py')
-rwxr-xr-xapp_templates/tdeioslave/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/app_templates/tdeioslave/setup.py b/app_templates/tdeioslave/setup.py
new file mode 100755
index 0000000..f2a5468
--- /dev/null
+++ b/app_templates/tdeioslave/setup.py
@@ -0,0 +1,30 @@
+#!/usr/bin/python
+###########################################################################
+# setup - description #
+# ------------------------------ #
+# begin : Fri Jun 27 2005 #
+# copyright : (C) 2005 by AUTHOR #
+# email : [email protected] #
+# #
+###########################################################################
+# #
+# This program is free software; you can redistribute it and/or modify #
+# it under the terms of the GNU General Public License as published by #
+# the Free Software Foundation; either version 2 of the License, or #
+# (at your option) any later version. #
+# #
+###########################################################################
+
+import kdedistutils
+
+kdedistutils.setup(name="tdeioslave",
+ version="0.1.0",
+ author="AUTHOR",
+ author_email="[email protected]",
+ url="http://www.TESTAPP.com/",
+ min_kde_version = "3.0.0",
+ min_qt_version = "3.0.0",
+ license = "GPL",
+ application_data = ['src/tdeioslave.py'],
+ docbooks = [ ('doc/en','en') ],
+ tdeioslaves = [ ('src/tdeioslave.protocol','tdeioslave.py')] )