summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <[email protected]>2011-11-26 13:19:22 -0600
committerTimothy Pearson <[email protected]>2011-11-26 13:19:22 -0600
commit0710d08800aa69ca9579416a3d4bb6220593f229 (patch)
tree29a1cf8936b04f9cc4be5a8618648ce99cec2cc8 /po/CMakeLists.txt
parent32e75dd020843a7a3dbb7d2df4ba6f0f234a69c5 (diff)
downloadrosegarden-0710d08800aa69ca9579416a3d4bb6220593f229.tar.gz
rosegarden-0710d08800aa69ca9579416a3d4bb6220593f229.zip
Initial attempt at migration to standard TDE CMake build system
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt38
1 files changed, 15 insertions, 23 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index a653d59..c752e63 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1,25 +1,17 @@
+#################################################
+#
+# (C) 2011 Timothy Pearson
+# kb9vqf (AT) pearsoncomputing.net
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
-# Automatic discovery of sources
-FILE(GLOB PO_FILES *.po)
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} rosegarden.po )
-# DISABLED: explicit set of source files
-# SET(PO_FILES
-# ca.po
-# cs.po
-# cy.po
-# de.po
-# en_GB.po
-# en.po
-# es.po
-# et.po
-# fi.po
-# fr.po
-# it.po
-# ja.po
-# nl.po
-# ru.po
-# sv.po
-# zh_CN.po
-# )
-
-ADD_TRANSLATIONS(rosegarden ${PO_FILES})
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} PATH )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )