summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2023-11-13 18:42:43 +0900
committerMichele Calgaro <[email protected]>2023-11-14 20:57:09 +0900
commit802b45c5566c3916e46250060ecef332f055fc26 (patch)
tree1bd49a5d76709e620040d6474dff725d1f8fbbc2 /src/CMakeLists.txt
parent300613eef3cbb63f040fcbced2e03570791d16f3 (diff)
downloadsoundkonverter-802b45c5566c3916e46250060ecef332f055fc26.tar.gz
soundkonverter-802b45c5566c3916e46250060ecef332f055fc26.zip
cmake conversion
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt69
1 files changed, 69 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..8d4feb3
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,69 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/metadata
+ ${CMAKE_CURRENT_SOURCE_DIR}/pluginloader
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+ ${CDPARANOIA_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TDE_LIB_DIR}
+)
+
+
+##### subfolders
+
+add_subdirectory( amarokscript )
+add_subdirectory( metadata )
+add_subdirectory( pics )
+add_subdirectory( pluginloader )
+add_subdirectory( plugins )
+
+
+##### soundkonverter (executable)
+
+tde_add_executable( soundkonverter AUTOMOC
+ SOURCES
+ cddb.cpp cdmanager.cpp cdopener.cpp combobutton.cpp
+ configuration.cpp configbackendspage.cpp configdialog.cpp configenvironmentpage.cpp
+ configgeneralpage.cpp configpagebase.cpp configpluginspage.cpp conversionoptions.cpp
+ convert.cpp cuesheeteditor.cpp dcopinterface.skel dirdialog.cpp filelist.cpp
+ logger.cpp logviewer.cpp main.cpp options.cpp optionsdetailed.cpp
+ optionseditor.cpp optionsrequester.cpp optionssimple.cpp outputdirectory.cpp paranoia.cpp
+ progressindicator.cpp replaygain.cpp replaygainfilelist.cpp replaygainscanner.cpp
+ soundkonverter.cpp soundkonverterapp.cpp
+ LINK
+ metadata-static tagspeex-static tagtrueaudio-static tagwavpack-static tagasf-static
+ tagwav-static tagrealmedia-static tagm4a-static tagaac-static tagaudible-static
+ tagmonkeysaudio-static tagoptimfrog-static pluginloader-static
+ tdecore-shared tdefx-shared tdeui-shared tdeio-shared tdetexteditor-shared DCOP-shared
+ ${TAGLIB_LIBRARIES} ${CDPARANOIA_LIBRARIES}
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### app icon
+
+tde_install_icons( ${PROJECT_NAME} )
+tde_install_icons( ${PROJECT_NAME}_replaygain )
+
+
+##### other files
+
+tde_create_translated_desktop(
+ SOURCE audiocd_extract_with_soundkonverter.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqueror/servicemenus
+)
+
+tde_create_translated_desktop(
+ SOURCE soundkonverter.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install(
+ FILES soundkonverterui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/soundkonverter
+)