summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 783616d..2e95052 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,13 @@ if( "${CMAKE_CURRENT_SOURCE_DIR}" STREQUAL "${CMAKE_SOURCE_DIR}" )
##### general package setup #####################
- cmake_minimum_required( VERSION 3.5 )
+ # building tde-cmake requires reading the minimum required version
+ # from the source files, because there may be a different version
+ # of tde-cmake already installed in the system. Trying to build
+ # tde-cmake with a lower minimum version would not be allowed then.
+
+ include( ${CMAKE_SOURCE_DIR}/modules/TDEVersion.cmake )
+ cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
project( tde-cmake-rules )