summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-07-19 15:23:47 +0900
committerMichele Calgaro <[email protected]>2024-07-19 15:23:47 +0900
commiteccae8f56589504832939ead309248dfb8b2d9af (patch)
treeb37891cdb797cdf93aa637b8141d9d443d059c4b /CMakeLists.txt
parent35b683a741ce46cb59ef380b2e3fffd567bec5ec (diff)
downloadtde-ebook-reader-eccae8f56589504832939ead309248dfb8b2d9af.tar.gz
tde-ebook-reader-eccae8f56589504832939ead309248dfb8b2d9af.zip
Fix loading of ZLibrary resources
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5568df4..0e62764 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,24 @@ include( TDESetupPaths )
tde_setup_paths( )
+##### zlibrary-tqt paths
+
+_tde_internal_setup_path(
+ ZL_SHARE_INSTALL_PREFIX "${CMAKE_ZLIBRARY_INSTALL_PREFIX}/share/zlibrary-tqt"
+ "Base directory for zlibrary-tqt files which go to share"
+)
+
+_tde_internal_setup_path(
+ ZL_INCLUDE_INSTALL_DIR "${CMAKE_ZLIBRARY_INSTALL_PREFIX}/include/zlibrary-tqt"
+ "The subdirectory to the header prefix"
+)
+
+_tde_internal_setup_path(
+ ZL_LIB_INSTALL_DIR "${CMAKE_ZLIBRARY_INSTALL_PREFIX}/lib${LIB_SUFFIX}"
+ "Base directory for zlibrary-tqt lib files"
+)
+
+
##### optional stuff
option( WITH_ALL_OPTIONS "Enable all optional support" OFF )