summaryrefslogtreecommitdiffstats
path: root/distributions/debian/maemo2/rules
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-05-11 21:28:48 +0900
committerMichele Calgaro <[email protected]>2024-05-11 21:28:48 +0900
commit2462d03f322261bd616721c2b2065c4004b36c9c (patch)
tree239947a0737bb8386703a1497f12c09aebd3080a /distributions/debian/maemo2/rules
downloadtde-ebook-reader-2462d03f322261bd616721c2b2065c4004b36c9c.tar.gz
tde-ebook-reader-2462d03f322261bd616721c2b2065c4004b36c9c.zip
Initial import (as is) from Debian Snapshot's 'fbreader' source code (https://snapshot.debian.org/package/fbreader/0.99.4%2Bdfsg-6).
The Debian code is provided under GPL2 license. Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'distributions/debian/maemo2/rules')
-rwxr-xr-xdistributions/debian/maemo2/rules66
1 files changed, 66 insertions, 0 deletions
diff --git a/distributions/debian/maemo2/rules b/distributions/debian/maemo2/rules
new file mode 100755
index 0000000..7ecda9f
--- /dev/null
+++ b/distributions/debian/maemo2/rules
@@ -0,0 +1,66 @@
+#!/usr/bin/make -f
+## ----------------------------------------------------------------------
+## debian/rules : package script for fbreader
+## ----------------------------------------------------------------------
+
+## ----------------------------------------------------------------------
+## uncomment this to turn on verbose mode
+#export DH_VERBOSE=1
+
+## ----------------------------------------------------------------------
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+
+## ----------------------------------------------------------------------
+DEB_DIR = $(CURDIR)/debian
+
+## ----------------------------------------------------------------------
+## targets
+
+clean:
+ dh_testdir
+ dh_testroot
+ [ ! -f Makefile ] || $(MAKE) distclean
+ dh_clean build-stamp install-stamp
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ $(MAKE) -C zlibrary/core TARGET_ARCH=maemo UI_TYPE=maemo2
+ $(MAKE) -C zlibrary/text TARGET_ARCH=maemo UI_TYPE=maemo2
+ $(MAKE) -C zlibrary/ui TARGET_ARCH=maemo UI_TYPE=maemo2
+ $(MAKE) -C fbreader TARGET_ARCH=maemo UI_TYPE=maemo2
+ touch build-stamp
+
+install: install-stamp
+install-stamp: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ $(MAKE) -C zlibrary/core TARGET_ARCH=maemo UI_TYPE=maemo2 DESTDIR=$(DEB_DIR)/libzlibrary-maemo2-noconic do_install
+ $(MAKE) -C zlibrary/text TARGET_ARCH=maemo UI_TYPE=maemo2 DESTDIR=$(DEB_DIR)/libzlibrary-maemo2-noconic do_install
+ $(MAKE) -C zlibrary/ui TARGET_ARCH=maemo UI_TYPE=maemo2 DESTDIR=$(DEB_DIR)/libzlibrary-maemo2-noconic do_install
+ $(MAKE) -C fbreader TARGET_ARCH=maemo UI_TYPE=maemo2 DESTDIR=$(DEB_DIR)/fbreader-maemo2 do_install
+ $(MAKE) -C zlibrary/core TARGET_ARCH=maemo UI_TYPE=maemo2 DESTDIR=$(DEB_DIR)/libzlibrary-maemo2-dev do_install_dev
+ $(MAKE) -C zlibrary/text TARGET_ARCH=maemo UI_TYPE=maemo2 DESTDIR=$(DEB_DIR)/libzlibrary-maemo2-dev do_install_dev
+ touch install-stamp
+
+binary-indep:
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_compress -a
+ dh_fixperms -a
+ dh_installdeb -a
+ dh_shlibdeps -a -l $(PWD)/debian/libzlibrary-maemo2/usr/lib
+ dh_gencontrol -a
+ dh_md5sums -a
+ dh_builddeb -a
+
+binary: binary-indep binary-arch
+
+.PHONY: clean build install binary-indep binary-arch binary
+
+## ----------------------------------------------------------------------