summaryrefslogtreecommitdiffstats
path: root/debian/patches/0004-prevent-so-install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0004-prevent-so-install.patch')
-rw-r--r--debian/patches/0004-prevent-so-install.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/patches/0004-prevent-so-install.patch b/debian/patches/0004-prevent-so-install.patch
new file mode 100644
index 0000000..9046382
--- /dev/null
+++ b/debian/patches/0004-prevent-so-install.patch
@@ -0,0 +1,23 @@
+Description: Prevent installing .so link in non-dev library pkgs
+Author: Bastian Germann <[email protected]>
+---
+--- fbreader-0.99.4+dfsg.orig/zlibrary/core/Makefile
++++ fbreader-0.99.4+dfsg/zlibrary/core/Makefile
+@@ -85,7 +85,6 @@ ifeq "$(ZLSHARED)" "yes"
+ @install -d $(DESTDIR)$(LIBDIR)
+ @install $(TARGET) $(DESTDIR)$(LIBDIR)
+ @ln -sf $(TARGET) $(DESTDIR)$(LIBDIR)/$(TARGET_SONAME)
+- @ln -sf $(TARGET) $(DESTDIR)$(LIBDIR)/$(TARGET_SHORTNAME)
+ endif
+
+ do_install_dev:
+--- fbreader-0.99.4+dfsg.orig/zlibrary/text/Makefile
++++ fbreader-0.99.4+dfsg/zlibrary/text/Makefile
+@@ -52,7 +52,6 @@ ifeq "$(ZLSHARED)" "yes"
+ @install -d $(DESTDIR)$(LIBDIR)
+ @install $(TARGET) $(DESTDIR)$(LIBDIR)
+ @ln -sf $(TARGET) $(DESTDIR)$(LIBDIR)/$(TARGET_SONAME)
+- @ln -sf $(TARGET) $(DESTDIR)$(LIBDIR)/$(TARGET_SHORTNAME)
+ endif
+
+ do_install_dev: