summaryrefslogtreecommitdiffstats
path: root/distributions/debian/maemo4/rules
diff options
context:
space:
mode:
Diffstat (limited to 'distributions/debian/maemo4/rules')
-rwxr-xr-xdistributions/debian/maemo4/rules66
1 files changed, 66 insertions, 0 deletions
diff --git a/distributions/debian/maemo4/rules b/distributions/debian/maemo4/rules
new file mode 100755
index 0000000..7e354c9
--- /dev/null
+++ b/distributions/debian/maemo4/rules
@@ -0,0 +1,66 @@
+#!/usr/bin/make -f
+## ----------------------------------------------------------------------
+## debian/rules : package script for fbreader
+## ----------------------------------------------------------------------
+
+## ----------------------------------------------------------------------
+## uncomment this to turn on verbose mode
+#export DH_VERBOSE=1
+
+## ----------------------------------------------------------------------
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+
+## ----------------------------------------------------------------------
+DEB_DIR = $(CURDIR)/debian
+
+## ----------------------------------------------------------------------
+## targets
+
+clean:
+ dh_testdir
+ dh_testroot
+ [ ! -f Makefile ] || $(MAKE) distclean
+ dh_clean build-stamp install-stamp
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ $(MAKE) -C zlibrary/core TARGET_ARCH=maemo UI_TYPE=maemo4
+ $(MAKE) -C zlibrary/text TARGET_ARCH=maemo UI_TYPE=maemo4
+ $(MAKE) -C zlibrary/ui TARGET_ARCH=maemo UI_TYPE=maemo4
+ $(MAKE) -C fbreader TARGET_ARCH=maemo UI_TYPE=maemo4
+ touch build-stamp
+
+install: install-stamp
+install-stamp: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ $(MAKE) -C zlibrary/core TARGET_ARCH=maemo UI_TYPE=maemo4 DESTDIR=$(DEB_DIR)/libzlibrary do_install
+ $(MAKE) -C zlibrary/text TARGET_ARCH=maemo UI_TYPE=maemo4 DESTDIR=$(DEB_DIR)/libzlibrary do_install
+ $(MAKE) -C zlibrary/ui TARGET_ARCH=maemo UI_TYPE=maemo4 DESTDIR=$(DEB_DIR)/libzlibrary do_install
+ $(MAKE) -C fbreader TARGET_ARCH=maemo UI_TYPE=maemo4 DESTDIR=$(DEB_DIR)/fbreader do_install
+ $(MAKE) -C zlibrary/core TARGET_ARCH=maemo UI_TYPE=maemo4 DESTDIR=$(DEB_DIR)/libzlibrary-dev do_install_dev
+ $(MAKE) -C zlibrary/text TARGET_ARCH=maemo UI_TYPE=maemo4 DESTDIR=$(DEB_DIR)/libzlibrary-dev do_install_dev
+ touch install-stamp
+
+binary-indep:
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_compress -a
+ dh_fixperms -a
+ dh_installdeb -a
+ dh_shlibdeps -a -l $(DEB_DIR)/libzlibrary/usr/lib
+ dh_gencontrol -a
+ dh_md5sums -a
+ dh_builddeb -a
+
+binary: binary-indep binary-arch
+
+.PHONY: clean build install binary-indep binary-arch binary
+
+## ----------------------------------------------------------------------