summaryrefslogtreecommitdiffstats
path: root/distributions/debian/smartq/patches
diff options
context:
space:
mode:
Diffstat (limited to 'distributions/debian/smartq/patches')
-rw-r--r--distributions/debian/smartq/patches/110-use-sensible-browser.patch11
-rw-r--r--distributions/debian/smartq/patches/120-key-names-and-actions.patch58
-rw-r--r--distributions/debian/smartq/patches/130-default-indicator.patch13
-rw-r--r--distributions/debian/smartq/patches/140-fullscreen-scrolling.patch41
-rw-r--r--distributions/debian/smartq/patches/150-default-rotation-direction.patch12
-rw-r--r--distributions/debian/smartq/patches/160-use-gcc-4-3.patch14
-rw-r--r--distributions/debian/smartq/patches/170-disable-selection-by-default.patch10
-rw-r--r--distributions/debian/smartq/patches/series7
8 files changed, 166 insertions, 0 deletions
diff --git a/distributions/debian/smartq/patches/110-use-sensible-browser.patch b/distributions/debian/smartq/patches/110-use-sensible-browser.patch
new file mode 100644
index 0000000..42098a1
--- /dev/null
+++ b/distributions/debian/smartq/patches/110-use-sensible-browser.patch
@@ -0,0 +1,11 @@
+--- fbreader-0.10.0.orig/fbreader/data/default/external.desktop.xml
++++ fbreader-0.10.0/fbreader/data/default/external.desktop.xml
+@@ -3,7 +3,7 @@
+ <section name="Web Browser">
+ <program name="%browser" protocol="execute">
+ <action name="openLink" command="%command"/>
+- <option name="command" defaultValue="mozilla %1 &amp;"/>
++ <option name="command" defaultValue="sensible-browser %1 &amp;"/>
+ </program>
+ </section>
+ </ExternalPrograms>
diff --git a/distributions/debian/smartq/patches/120-key-names-and-actions.patch b/distributions/debian/smartq/patches/120-key-names-and-actions.patch
new file mode 100644
index 0000000..e6cae59
--- /dev/null
+++ b/distributions/debian/smartq/patches/120-key-names-and-actions.patch
@@ -0,0 +1,58 @@
+--- fbreader-0.12.2.orig/fbreader/data/default/keymap.desktop.xml
++++ fbreader-0.12.2/fbreader/data/default/keymap.desktop.xml
+@@ -1,36 +1,8 @@
+ <?xml version="1.0" encoding="UTF-8"?>
+ <keymap>
+- <binding key="&lt;L&gt;" action="showLibrary"/>
+- <binding key="&lt;W&gt;" action="showNetLibrary"/>
+- <binding key="&lt;O&gt;" action="preferences"/>
+- <binding key="&lt;LeftArrow&gt;" action="undo"/>
+- <binding key="&lt;RightArrow&gt;" action="redo"/>
+- <binding key="&lt;C&gt;" action="toc"/>
+- <binding key="&lt;Ctrl&gt;+&lt;F&gt;" action="search"/>
+- <binding key="&lt;F&gt;" action="search"/>
+- <binding key="&lt;P&gt;" action="findPrevious"/>
+- <binding key="&lt;F3&gt;" action="findNext"/>
+- <binding key="&lt;N&gt;" action="findNext"/>
+ <binding key="&lt;PageDown&gt;" action="pageForward"/>
+ <binding key="&lt;PageUp&gt;" action="pageBackward"/>
+- <binding key="&lt;DownArrow&gt;" action="lineForward"/>
+- <binding key="&lt;UpArrow&gt;" action="lineBackward"/>
+- <binding key="&lt;MouseScrollDown&gt;" action="mouseScrollForward"/>
+- <binding key="&lt;MouseScrollUp&gt;" action="mouseScrollBackward"/>
+- <binding key="&lt;Ctrl&gt;+&lt;Home&gt;" action="gotoHome"/>
+- <binding key="&lt;Home&gt;" action="gotoSectionStart"/>
+- <binding key="&lt;End&gt;" action="gotoSectionEnd"/>
++ <binding key="&lt;Return&gt;" action="rotate"/>
++ <binding key="&lt;FullScreen&gt;" action="toggleFullscreen"/>
+ <binding key="&lt;Esc&gt;" action="cancel"/>
+- <binding key="&lt;=&gt;" action="increaseFont"/>
+- <binding key="&lt;-&gt;" action="decreaseFont"/>
+- <binding key="&lt;D&gt;" action="toggleIndicator"/>
+- <binding key="&lt;Return&gt;" action="toggleFullscreen"/>
+- <binding key="&lt;A&gt;" action="addBook"/>
+- <binding key="&lt;I&gt;" action="bookInfo"/>
+- <binding key="&lt;R&gt;" action="rotate"/>
+- <binding key="&lt;Ctrl&gt;+&lt;DownArrow&gt;" action="nextTOCSection"/>
+- <binding key="&lt;Ctrl&gt;+&lt;UpArrow&gt;" action="previousTOCSection"/>
+- <binding key="&lt;Ctrl&gt;+&lt;C&gt;" action="copyToClipboard"/>
+- <binding key="&lt;G&gt;" action="gotoPageNumber"/>
+- <binding key="&lt;Z&gt;" action="debugNL"/>
+ </keymap>
+--- fbreader-0.12.2.orig/zlibrary/ui/data/keynames.desktop-gtk.xml
++++ fbreader-0.12.2/zlibrary/ui/data/keynames.desktop-gtk.xml
+@@ -1,5 +1,6 @@
+ <?xml version="1.0" encoding="UTF-8"?>
+ <keynames>
++ <key code="0xFFE9" name="&lt;FullScreen&gt;"/>
+ <key code="0xFF1B" name="&lt;Esc&gt;"/>
+ <key code="0x1B" name="&lt;Esc&gt;"/>
+ <key code="0xFF09" name="&lt;Tab&gt;"/>
+@@ -41,7 +42,6 @@
+ <key code="0xFFE2" name="&lt;RShift&gt;"/>
+ <key code="0xFFE3" name="&lt;Ctrl&gt;"/>
+ <key code="0xFE08" name="&lt;RCtrl&gt;"/>
+- <key code="0xFFE9" name="&lt;Alt&gt;"/>
+ <key code="0xFFEA" name="&lt;RAlt&gt;"/>
+ <key code="0xFFEB" name="&lt;Win&gt;"/>
+ <key code="0xFF6B" name="&lt;Break&gt;"/>
diff --git a/distributions/debian/smartq/patches/130-default-indicator.patch b/distributions/debian/smartq/patches/130-default-indicator.patch
new file mode 100644
index 0000000..e242f43
--- /dev/null
+++ b/distributions/debian/smartq/patches/130-default-indicator.patch
@@ -0,0 +1,13 @@
+--- fbreader-0.12.2.orig/fbreader/data/default/config.desktop.xml
++++ fbreader-0.12.2/fbreader/data/default/config.desktop.xml
+@@ -4,6 +4,10 @@
+ <option name="Base:fontFamily" value="Georgia"/>
+ <option name="Base:fontSize" value="16"/>
+ </group>
++ <group name="Indicator">
++ <option name="Type" value="1"/>
++ <option name="Time" value="true"/>
++ </group>
+ <group name="Scrollings">
+ <option name="Delay" value="0"/>
+ </group>
diff --git a/distributions/debian/smartq/patches/140-fullscreen-scrolling.patch b/distributions/debian/smartq/patches/140-fullscreen-scrolling.patch
new file mode 100644
index 0000000..d6c9543
--- /dev/null
+++ b/distributions/debian/smartq/patches/140-fullscreen-scrolling.patch
@@ -0,0 +1,41 @@
+--- fbreader-0.12.2.orig/zlibrary/ui/src/gtk/view/ZLGtkViewWidget.cpp
++++ fbreader-0.12.2/zlibrary/ui/src/gtk/view/ZLGtkViewWidget.cpp
+@@ -203,7 +204,6 @@
+ ZLGtkSignalUtil::connectSignal(GTK_OBJECT(myArea), "button_release_event", GTK_SIGNAL_FUNC(mouseReleased), this);
+ ZLGtkSignalUtil::connectSignal(GTK_OBJECT(myArea), "motion_notify_event", GTK_SIGNAL_FUNC(mouseMoved), this);
+ ZLGtkSignalUtil::connectSignal(GTK_OBJECT(myArea), "expose_event", GTK_SIGNAL_FUNC(::doPaint), this);
+- myRepaintBlocked = false;
+ }
+
+ void ZLGtkViewWidget::setScrollbarEnabled(ZLView::Direction direction, bool enabled) {
+@@ -292,9 +292,7 @@
+ }
+
+ void ZLGtkViewWidget::repaint() {
+- if (!myRepaintBlocked) {
+- gtk_widget_queue_draw(myArea);
+- }
++ gtk_widget_queue_draw(myArea);
+ }
+
+ void ZLGtkViewWidget::doPaint() {
+@@ -352,9 +350,6 @@
+ gdk_draw_pixbuf(myArea->window, myArea->style->white_gc, myRotatedPixbuf, 0, 0, 0, 0, h, w, GDK_RGB_DITHER_NONE, 0, 0);
+ break;
+ }
+- myRepaintBlocked = true;
+- myApplication->refreshWindow();
+- myRepaintBlocked = false;
+ }
+
+ GtkWidget *ZLGtkViewWidget::area() {
+--- fbreader-0.12.2.orig/zlibrary/ui/src/gtk/view/ZLGtkViewWidget.h
++++ fbreader-0.12.2/zlibrary/ui/src/gtk/view/ZLGtkViewWidget.h
+@@ -61,7 +61,6 @@
+ GdkPixbuf *myOriginalPixbuf;
+ GdkPixbuf *myRotatedPixbuf;
+ GdkImage *myImage;
+- bool myRepaintBlocked;
+
+ GtkAdjustment *myVerticalAdjustment;
+ GtkWidget *myRightScrollBar;
diff --git a/distributions/debian/smartq/patches/150-default-rotation-direction.patch b/distributions/debian/smartq/patches/150-default-rotation-direction.patch
new file mode 100644
index 0000000..6ff1798
--- /dev/null
+++ b/distributions/debian/smartq/patches/150-default-rotation-direction.patch
@@ -0,0 +1,12 @@
+--- fbreader-0.12.2.orig/fbreader/data/default/config.desktop.xml
++++ fbreader-0.12.2/fbreader/data/default/config.desktop.xml
+@@ -9,6 +9,9 @@
+ <option name="PositionText" value="true"/>
+ <option name="Time" value="true"/>
+ </group>
++ <group name="Rotation">
++ <option name="Angle" value="270"/>
++ </group>
+ <group name="Scrollings">
+ <option name="Delay" value="0"/>
+ </group>
diff --git a/distributions/debian/smartq/patches/160-use-gcc-4-3.patch b/distributions/debian/smartq/patches/160-use-gcc-4-3.patch
new file mode 100644
index 0000000..a1741ab
--- /dev/null
+++ b/distributions/debian/smartq/patches/160-use-gcc-4-3.patch
@@ -0,0 +1,14 @@
+--- fbreader-0.12.2.orig/makefiles/arch/desktop.mk 2010-02-13 08:04:07.000000000 +0000
++++ fbreader-0.12.2/makefiles/arch/desktop.mk 2010-02-13 10:26:41.000000000 +0000
+@@ -6,9 +6,9 @@
+ IMAGEDIR = $(INSTALLDIR)/share/pixmaps
+ APPIMAGEDIR = $(INSTALLDIR)/share/pixmaps/%APPLICATION_NAME%
+
+-CC = gcc
++CC = gcc-4.3
+ AR = ar rsu
+-LD = g++
++LD = g++-4.3
+
+ CFLAGS = -pipe -fno-exceptions -Wall -Wno-ctor-dtor-privacy -W -DLIBICONV_PLUG
+ LDFLAGS =
diff --git a/distributions/debian/smartq/patches/170-disable-selection-by-default.patch b/distributions/debian/smartq/patches/170-disable-selection-by-default.patch
new file mode 100644
index 0000000..0051c54
--- /dev/null
+++ b/distributions/debian/smartq/patches/170-disable-selection-by-default.patch
@@ -0,0 +1,10 @@
+--- fbreader-0.12.2.orig/fbreader/data/default/config.desktop.xml
++++ fbreader-0.12.2/fbreader/data/default/config.desktop.xml
+@@ -15,6 +15,7 @@
+ <option name="Delay" value="0"/>
+ </group>
+ <group name="Options">
++ <option name="IsSelectionEnabled" value="false"/>
+ <option name="LeftMargin" value="50"/>
+ <option name="RightMargin" value="50"/>
+ <option name="KeyDelay" value="0"/>
diff --git a/distributions/debian/smartq/patches/series b/distributions/debian/smartq/patches/series
new file mode 100644
index 0000000..e0c0dc2
--- /dev/null
+++ b/distributions/debian/smartq/patches/series
@@ -0,0 +1,7 @@
+110-use-sensible-browser.patch
+120-key-names-and-actions.patch
+130-default-indicator.patch
+140-fullscreen-scrolling.patch
+150-default-rotation-direction.patch
+160-use-gcc-4-3.patch
+170-disable-selection-by-default.patch