summaryrefslogtreecommitdiffstats
path: root/dev-libs/dbus-1-tqt/dbus-1-tqt-14.1.2.ebuild
diff options
context:
space:
mode:
authorormorph <[email protected]>2024-04-28 17:23:47 +0300
committerormorph <[email protected]>2024-04-28 22:35:54 +0300
commit30335515923be5f5ee02981121d2cdb6ad89978d (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /dev-libs/dbus-1-tqt/dbus-1-tqt-14.1.2.ebuild
parent929431cac813bc953a1e646fe36d1cfbc4a68f4b (diff)
downloadtde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.tar.gz
tde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <[email protected]>
Diffstat (limited to 'dev-libs/dbus-1-tqt/dbus-1-tqt-14.1.2.ebuild')
-rw-r--r--dev-libs/dbus-1-tqt/dbus-1-tqt-14.1.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/dbus-1-tqt/dbus-1-tqt-14.1.2.ebuild b/dev-libs/dbus-1-tqt/dbus-1-tqt-14.1.2.ebuild
new file mode 100644
index 00000000..1727a4fd
--- /dev/null
+++ b/dev-libs/dbus-1-tqt/dbus-1-tqt-14.1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="dbus-1-tqt"
+inherit trinity-base-2
+
+DESCRIPTION="D-BUS TQt bindings"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="sys-apps/dbus
+ ~dev-tqt/tqtinterface-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ cmake_src_configure
+}