summaryrefslogtreecommitdiffstats
path: root/dev-libs/dbus-tqt/dbus-tqt-14.0.12.ebuild
diff options
context:
space:
mode:
authorormorph <[email protected]>2022-04-30 20:47:27 +0300
committerSlávek Banko <[email protected]>2022-05-01 16:23:29 +0200
commit336d8ce82c00a00153a823a187dbc8e0bcf2c7a1 (patch)
tree920bb9b62e96c92b2a5a7e99352e68afb2783ce8 /dev-libs/dbus-tqt/dbus-tqt-14.0.12.ebuild
parent1c8d53512742aab368c0f7e9973604eaa54b43ba (diff)
downloadtde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.tar.gz
tde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.zip
Added version 14.0.12
Signed-off-by: ormorph <[email protected]>
Diffstat (limited to 'dev-libs/dbus-tqt/dbus-tqt-14.0.12.ebuild')
-rw-r--r--dev-libs/dbus-tqt/dbus-tqt-14.0.12.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/dbus-tqt/dbus-tqt-14.0.12.ebuild b/dev-libs/dbus-tqt/dbus-tqt-14.0.12.ebuild
new file mode 100644
index 00000000..b102d1c5
--- /dev/null
+++ b/dev-libs/dbus-tqt/dbus-tqt-14.0.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="dbus-tqt"
+inherit trinity-base-2
+
+DESCRIPTION="D-BUS TQt bindings"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="sys-apps/dbus
+ ~dev-tqt/tqtinterface-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ cmake_src_configure
+}