summaryrefslogtreecommitdiffstats
path: root/dev-python/pytqt
diff options
context:
space:
mode:
authorormorph <[email protected]>2023-04-22 11:30:51 +0300
committerormorph <[email protected]>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /dev-python/pytqt
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <[email protected]>
Diffstat (limited to 'dev-python/pytqt')
-rw-r--r--dev-python/pytqt/Manifest1
-rw-r--r--dev-python/pytqt/pytqt-14.1.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pytqt/Manifest b/dev-python/pytqt/Manifest
new file mode 100644
index 00000000..fa3ab172
--- /dev/null
+++ b/dev-python/pytqt/Manifest
@@ -0,0 +1 @@
+DIST pytqt-trinity-14.1.0.tar.xz 461532 BLAKE2B e639008c5948eab5755219f7f87fca2bf53e07f616f9e4041b3462d2c095473be97198dae3079efaa01c72981ed270fbbfd8aeb37a331741f7c464f54f07b6dd SHA512 8ddcac9bc79e34c9f86de5becb9cbf5efa5a834b091ab8b108ecde8b9f725fad3101917bed072de5e96a502a9a1d85cc4c115ac89c2341b9d6dacca0e852cf60
diff --git a/dev-python/pytqt/pytqt-14.1.0.ebuild b/dev-python/pytqt/pytqt-14.1.0.ebuild
new file mode 100644
index 00000000..1eb897eb
--- /dev/null
+++ b/dev-python/pytqt/pytqt-14.1.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2022-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit trinity-base-2 python-single-r1 flag-o-matic
+
+DESCRIPTION="TQt bindings for Python"
+HOMEPAGE="https://trinitydesktop.org/"
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ ~dev-python/sip4-tqt-${PV}
+ ~x11-libs/tqscintilla-${PV}
+ ~dev-tqt/tqtinterface-${PV}
+"
+RDEPEND="${DEPEND}"
+
+TQBASE="/usr/tqt3"
+BUILD_DIR="${S}"
+
+src_prepare() {
+ eapply_user
+}
+
+src_configure() {
+ append-cflags "-I/usr/include/tqt -I/${TQBASE}/include"
+ append-cxxflags "-I/usr/include/tqt -I/${TQBASE}/include"
+ local myconf
+ myconf=(
+ -g "${TQBASE}/include"
+ -q "${TQBASE}"
+ -y tqt-mt
+ -o "${TQBASE}/$(get_libdir)" -u -j 10
+ -d "$(python_get_sitedir)/PyTQt"
+ -v "${TQBASE}/sip/tqt"
+ -b "${TQBASE}/bin"
+ -w
+ )
+ echo yes | "${EPYTHON}" configure.py "${myconf[@]}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"|| die
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ if use examples ; then
+ insinto "${TQBASE}/share/pytqt/examples"
+ doins examples/*
+ local EDIR
+ for EDIR in SQL canvas i18n webbrowser
+ do
+ insinto "${TQBASE}/share/pytqt/examples/${EDIR}"
+ doins "examples/${EDIR}"/*
+ done
+ fi
+}