summaryrefslogtreecommitdiffstats
path: root/dev-tqt/tqt/tqt-14.0.6.ebuild
diff options
context:
space:
mode:
authorChris <[email protected]>2020-04-23 02:45:41 +0200
committerChris <[email protected]>2020-04-23 02:45:41 +0200
commit7e24157247073f424e1977f7ddd725f101d8ef55 (patch)
treee5429cb04a3f21bd17d5d75e8dfb6c3a8363ff6e /dev-tqt/tqt/tqt-14.0.6.ebuild
parentc5c06e25055403061b247d34f97e773ebed2bf1d (diff)
downloadtde-packaging-gentoo-7e24157247073f424e1977f7ddd725f101d8ef55.tar.gz
tde-packaging-gentoo-7e24157247073f424e1977f7ddd725f101d8ef55.zip
Stable ebuilds: General cosmetics and sync with live ebuilds.
Also: Some cosmetics for the live ebuilds. Signed-off-by: Chris <[email protected]>
Diffstat (limited to 'dev-tqt/tqt/tqt-14.0.6.ebuild')
-rw-r--r--dev-tqt/tqt/tqt-14.0.6.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-tqt/tqt/tqt-14.0.6.ebuild b/dev-tqt/tqt/tqt-14.0.6.ebuild
index 7157c8ff..c74133b5 100644
--- a/dev-tqt/tqt/tqt-14.0.6.ebuild
+++ b/dev-tqt/tqt/tqt-14.0.6.ebuild
@@ -2,9 +2,9 @@
# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="7"
-inherit eutils flag-o-matic toolchain-funcs
+inherit eutils toolchain-funcs
SRCTYPE="free"
DESCRIPTION="Trinity's Qt3 toolkit fork - a comprehensive C++ application development framework."
@@ -165,21 +165,21 @@ src_configure() {
src_compile() {
# Compile TQt with TQmake and TQmoc
- emake src-qmake src-moc sub-src || die
+ emake src-qmake src-moc sub-src
# Compile TQt plugins (if any selected)
- emake sub-plugins || die
+ emake sub-plugins
# Point to libs for the tools to build fine too
export DYLD_LIBRARY_PATH="${S}/lib:${DYLD_LIBRARY_PATH}"
export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
# Compile TQDesigner (TQuic is needed by tdelibs), TQAssistant and friends (msg2tqm, qembed..)
- emake sub-tools || die
+ emake sub-tools
# Compile examples and tutorials
if use examples; then
- emake sub-tutorial sub-examples || die
+ emake sub-tutorial sub-examples
fi
}