summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kdiff3/kdiff3-14.1.1.ebuild
diff options
context:
space:
mode:
authorormorph <[email protected]>2023-10-27 13:50:17 +0300
committerSlávek Banko <[email protected]>2023-10-29 10:05:05 +0100
commit271fc0de62480ffa8a1525e07b833079c96ca6bd (patch)
treefe24a566266198330ff71db390413fdf7a9d63af /trinity-apps/kdiff3/kdiff3-14.1.1.ebuild
parent8e955e3a507fd32d4b98df0893bb2dfa83b48eb8 (diff)
downloadtde-packaging-gentoo-271fc0de62480ffa8a1525e07b833079c96ca6bd.tar.gz
tde-packaging-gentoo-271fc0de62480ffa8a1525e07b833079c96ca6bd.zip
Release R14.1.1 added
Signed-off-by: ormorph <[email protected]> (cherry picked from commit 18d39ed9f062321b596258a9137f10b3e93b71e0)
Diffstat (limited to 'trinity-apps/kdiff3/kdiff3-14.1.1.ebuild')
-rw-r--r--trinity-apps/kdiff3/kdiff3-14.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/trinity-apps/kdiff3/kdiff3-14.1.1.ebuild b/trinity-apps/kdiff3/kdiff3-14.1.1.ebuild
new file mode 100644
index 00000000..6f5403fc
--- /dev/null
+++ b/trinity-apps/kdiff3/kdiff3-14.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar az bg br ca cs cy da de el es et fr ga gl hi hu is it ja
+ ka lt nb nl pl pt pt_BR ro ru rw sk sr sr@Latn sv ta tg tr uk zh_CN"
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="A diff and merge program for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}