summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kshutdown
diff options
context:
space:
mode:
authorE. Liddell <[email protected]>2020-12-06 16:11:21 -0500
committerTDE Gitea <[email protected]>2021-02-17 16:47:41 +0000
commitf0575f757d3a116ae806b578b37ae4b375a8caf5 (patch)
tree9055d8aa3000cc5d7a90675a7cc27d0d3d54acef /trinity-apps/kshutdown
parent32f776ede66c742cd2dceecb3739b083ac41d92b (diff)
downloadtde-packaging-gentoo-f0575f757d3a116ae806b578b37ae4b375a8caf5.tar.gz
tde-packaging-gentoo-f0575f757d3a116ae806b578b37ae4b375a8caf5.zip
14.0.8 ebuilds for everything in trinity-apps that I could make build back in June.
Signed-off-by: E. Liddell <[email protected]>
Diffstat (limited to 'trinity-apps/kshutdown')
-rw-r--r--trinity-apps/kshutdown/Manifest2
-rw-r--r--trinity-apps/kshutdown/kshutdown-14.0.8.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/trinity-apps/kshutdown/Manifest b/trinity-apps/kshutdown/Manifest
new file mode 100644
index 00000000..e543f7ba
--- /dev/null
+++ b/trinity-apps/kshutdown/Manifest
@@ -0,0 +1,2 @@
+DIST kshutdown-trinity-14.0.7.tar.xz 445412 BLAKE2B 2f7c9c7a2d3aca565f13e5f1bf40e71b30b6c72fd02139a6b348253bb6dcd3c277e9c3908c466e3ae50dd3ec8544e8f5fe0288c753d6ca88ef0cfc7f4845b527 SHA512 dfe87657e8ac5a254723ceb07b61029f6386cabadc3e6a3ebe90e2e72de896ba9b5acd010a917545909f0ddc24cad51ed0989096ef61af73cb7847e30e041f30
+DIST kshutdown-trinity-14.0.8.tar.xz 193928 BLAKE2B 97ad5c5f80adcfeadc72ecbbf1c7b6d1c728814a1597ec5c9b0034d70b8d2cfa8f69b935becb89e850c7617664d6846e1f4d674481f6b30c9c6423d25e993fcb SHA512 d12f541e89581c0567a39c6939fe0e7aca1594930b78f33d0311ea08e9a9dd7c378b86fb22ad50be82f89726e11ea2249271c4362035ea4445b8ae96a617e435
diff --git a/trinity-apps/kshutdown/kshutdown-14.0.8.ebuild b/trinity-apps/kshutdown/kshutdown-14.0.8.ebuild
new file mode 100644
index 00000000..59aa737d
--- /dev/null
+++ b/trinity-apps/kshutdown/kshutdown-14.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs de es fr hu it nl pl pt_BR ru sk sv tr zh_CN"
+
+TRINITY_DOC_LANGS="de"
+
+inherit trinity-base-2
+
+DESCRIPTION="A graphical shutdown utility for TDE"
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+IUSE+=" extras"
+
+RDEPEND+="
+ =trinity-base/tdesu-${PV}
+ =trinity-base/kcontrol-${PV}
+ =trinity-base/kdialog-${PV}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DBUILD_EXTRAS="$(usex extras)"
+ )
+
+ trinity-base-2_src_configure
+}