summaryrefslogtreecommitdiffstats
path: root/trinity-base/kicker/kicker-14.1.2.ebuild
diff options
context:
space:
mode:
authorormorph <[email protected]>2024-04-28 17:23:47 +0300
committerSlávek Banko <[email protected]>2024-04-29 00:52:31 +0200
commit94ec1d06986a97431ffc44951e92b075da19b93b (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /trinity-base/kicker/kicker-14.1.2.ebuild
parent08657933720cc4345cdf62e1d42f199d8225e458 (diff)
downloadtde-packaging-gentoo-94ec1d06986a97431ffc44951e92b075da19b93b.tar.gz
tde-packaging-gentoo-94ec1d06986a97431ffc44951e92b075da19b93b.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <[email protected]> (cherry picked from commit 30335515923be5f5ee02981121d2cdb6ad89978d)
Diffstat (limited to 'trinity-base/kicker/kicker-14.1.2.ebuild')
-rw-r--r--trinity-base/kicker/kicker-14.1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/trinity-base/kicker/kicker-14.1.2.ebuild b/trinity-base/kicker/kicker-14.1.2.ebuild
new file mode 100644
index 00000000..239566b7
--- /dev/null
+++ b/trinity-base/kicker/kicker-14.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_TYPE="core"
+inherit trinity-meta-2
+
+DESCRIPTION="The Trinity application starter panel, capable of applets and extensions"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="xcomposite hwlib"
+
+DEPEND="~trinity-base/libkonq-${PV}
+ ~trinity-base/tdebase-data-${PV}
+ ~dev-libs/dbus-tqt-${PV}
+ xcomposite? ( x11-libs/libXrender
+ x11-libs/libXfixes
+ x11-libs/libXcomposite )"
+
+RDEPEND="${DEPEND}
+ ~trinity-base/kmenuedit-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_XFIXES="$(usex xcomposite)"
+ -DWITH_XRENDER="$(usex xcomposite)"
+ -DWITH_XCOMPOSITE="$(usex xcomposite)"
+ -DWITH_TDEHWLIB="$(usex hwlib)"
+ )
+
+ trinity-meta-2_src_configure
+}