summaryrefslogtreecommitdiffstats
path: root/trinity-base/klaptopdaemon/klaptopdaemon-14.0.6.ebuild
diff options
context:
space:
mode:
authorE. Liddell <[email protected]>2020-05-03 16:55:54 -0400
committerE. Liddell <[email protected]>2020-05-03 16:55:54 -0400
commitf83d2c937f8dbf8162aa91294c51b80690ede40a (patch)
tree6fba723958c0da717c72a2003b631c96b7a6161c /trinity-base/klaptopdaemon/klaptopdaemon-14.0.6.ebuild
parentabe9ae9ee08593e76d3e2a44a49010384d29d872 (diff)
downloadtde-packaging-gentoo-f83d2c937f8dbf8162aa91294c51b80690ede40a.tar.gz
tde-packaging-gentoo-f83d2c937f8dbf8162aa91294c51b80690ede40a.zip
14.0.6 and 14.0.7 ebuilds for tdeutils
Diffstat (limited to 'trinity-base/klaptopdaemon/klaptopdaemon-14.0.6.ebuild')
-rw-r--r--trinity-base/klaptopdaemon/klaptopdaemon-14.0.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/trinity-base/klaptopdaemon/klaptopdaemon-14.0.6.ebuild b/trinity-base/klaptopdaemon/klaptopdaemon-14.0.6.ebuild
new file mode 100644
index 00000000..e9dfd119
--- /dev/null
+++ b/trinity-base/klaptopdaemon/klaptopdaemon-14.0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+EAPI="7"
+TRINITY_MODULE_NAME="tdeutils"
+
+inherit trinity-meta-2
+
+DESCRIPTION="KLaptopdaemon - Trinity battery monitoring and management for laptops."
+
+IUSE="xscreensaver"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-libs/libXtst
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ virtual/os-headers"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_DPMS=ON
+ -DWITH_XSCREENSAVER="$(usex xscreensaver)"
+ )
+
+ trinity-meta-2_src_configure
+}