summaryrefslogtreecommitdiffstats
path: root/trinity-base/kopete/kopete-9999.ebuild
diff options
context:
space:
mode:
authorAndreas Sturmlechner <[email protected]>2020-09-21 20:50:57 +0200
committerAndreas Sturmlechner <[email protected]>2020-09-22 02:13:34 +0200
commit5f3d9ab06c36b9faeb8e46254a62137161632922 (patch)
tree4f31227a4b183ad00caabca08bbb73da5ed94882 /trinity-base/kopete/kopete-9999.ebuild
parent11ee5ea7cf027da8dfb80b71b6164a417122f2e1 (diff)
downloadtde-packaging-gentoo-5f3d9ab06c36b9faeb8e46254a62137161632922.tar.gz
tde-packaging-gentoo-5f3d9ab06c36b9faeb8e46254a62137161632922.zip
trinity-base/kopete: Add missing IUSE metadata
- Sort IUSE, PLUGINS, PROTOCOLS - local mycmakeargs Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <[email protected]>
Diffstat (limited to 'trinity-base/kopete/kopete-9999.ebuild')
-rw-r--r--trinity-base/kopete/kopete-9999.ebuild39
1 files changed, 20 insertions, 19 deletions
diff --git a/trinity-base/kopete/kopete-9999.ebuild b/trinity-base/kopete/kopete-9999.ebuild
index c81d2cc9..e07887e8 100644
--- a/trinity-base/kopete/kopete-9999.ebuild
+++ b/trinity-base/kopete/kopete-9999.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-TRINITY_MODULE_NAME="tdenetwork"
+TRINITY_MODULE_NAME="tdenetwork"
inherit trinity-meta-2
DESCRIPTION="Trinity multi-protocol IM client"
-IUSE="jingle gsmlib netmeeting speex kernel_linux"
-PLUGINS="latex autoreplace history contactnotes crypt connectionstatus
- translator nowlistening webpresence texteffect highlight alias
- motionautoaway netmeeting addbookmarks statistics smpppdcs"
-PROTOCOLS="gadu groupwise irc xmpp oscar msn sms sametime winpopup yahoo"
+IUSE="gsmlib jingle kernel_linux netmeeting speex"
+PLUGINS="addbookmarks alias autoreplace connectionstatus contactnotes crypt
+ highlight history latex motionautoaway netmeeting nowlistening smpppdcs
+ statistics texteffect translator webpresence"
+PROTOCOLS="gadu groupwise irc msn oscar sametime sms winpopup xmpp yahoo"
# unsupported USE="v4l2 opengl xscreensaver ssl emoticons-manager "
# USE=xmms works only with xmms1
IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
@@ -23,19 +23,20 @@ REQUIRED_USE="
netmeeting? ( msn )
speex? ( jingle xmpp )"
-# MISSING BOTH_DEPEND
+# MISSING COMMON_DEPEND
# x11-libs/libXrender
# xmpp? ( net-dns/libidn )
# kernel_linux? ( virtual/opengl )
# opengl? ( dev-qt/qt-meta[opengl] )
# xscreensaver? ( x11-libs/libXScrnSaver )
# xmpp|groupwice? =app-crypt/qca-1.0*
-BOTH_DEPEND="
+COMMON_DEPEND="
jingle? ( dev-libs/glib )
netmeeting? ( dev-libs/glib )
webpresence? (
dev-libs/libxml2
- dev-libs/libxslt )
+ dev-libs/libxslt
+ )
jingle? (
dev-libs/expat
speex? ( media-libs/speex )
@@ -52,27 +53,27 @@ BOTH_DEPEND="
# x11-libs/libXv
# )
# xscreensaver? ( x11-proto/scrnsaverproto )
-DEPEND="${BOTH_DEPEND}
- kernel_linux? (
- virtual/os-headers
- )
+DEPEND="${COMMON_DEPEND}
+ kernel_linux? ( virtual/os-headers )
"
# MISSING RDEPEND
# netmeeting? ( net-voip/ekiga )
# ssl? ( =app-crypt/qca-tls-1.0* )
-RDEPEND="${BOTH_DEPEND}
+RDEPEND="${COMMON_DEPEND}
crypt? ( app-crypt/gnupg )
latex? (
media-gfx/imagemagick
- virtual/latex-base )
+ virtual/latex-base
+ )
sms? ( !gsmlib? ( || (
- app-mobilephone/smsclient
- app-mobilephone/smssend ) ) )
+ app-mobilephone/smsclient
+ app-mobilephone/smssend
+ ) ) )
"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DWITH_JINGLE="$(usex jingle)"
-DWITH_GSM="$(usex gsmlib)"
-DWITH_WEBCAM="$(usex netmeeting)"