summaryrefslogtreecommitdiffstats
path: root/www-misc/hldig/hldig-1.0.2.ebuild
diff options
context:
space:
mode:
authorormorph <[email protected]>2021-12-06 00:15:19 +0300
committerormorph <[email protected]>2021-12-06 07:33:16 +0300
commit3d92bd162a0ed612d020988b6350a5665c9f1ece (patch)
tree3d7595fc034fd383d66c0d5343eeb9e68d2b35bd /www-misc/hldig/hldig-1.0.2.ebuild
parent20d2cdcc6ed13b40485942e8531fd8f8516bcbbe (diff)
downloadtde-packaging-gentoo-3d92bd162a0ed612d020988b6350a5665c9f1ece.tar.gz
tde-packaging-gentoo-3d92bd162a0ed612d020988b6350a5665c9f1ece.zip
Dependencies fixes
Signed-off-by: ormorph <[email protected]>
Diffstat (limited to 'www-misc/hldig/hldig-1.0.2.ebuild')
-rw-r--r--www-misc/hldig/hldig-1.0.2.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/www-misc/hldig/hldig-1.0.2.ebuild b/www-misc/hldig/hldig-1.0.2.ebuild
index e25cdb4f..51cdf926 100644
--- a/www-misc/hldig/hldig-1.0.2.ebuild
+++ b/www-misc/hldig/hldig-1.0.2.ebuild
@@ -4,7 +4,7 @@
EAPI="7"
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="HTTP/HTML indexing and searching system"
HOMEPAGE="https://github.com/solbu/hldig"
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/solbu/${PN}/archive/v${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
-IUSE="libressl ssl"
+IUSE="ssl"
# Don't use Gentoo mirrors
RESTRICT="mirror"
@@ -21,10 +21,7 @@ RESTRICT="mirror"
DEPEND="
app-arch/unzip
sys-libs/zlib
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
+ ssl? ( dev-libs/openssl:= )
"
RDEPEND="${DEPEND}
!www-misc/htdig
@@ -41,6 +38,7 @@ src_prepare() {
}
src_configure() {
+ append-cxxflags "-std=c++11"
local myeconfargs=(
--disable-static
--with-config-dir="${EPREFIX}"/etc/${PN}