summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/gtk-qt-engine/debian/cdbs/debian-qt-kde.mk
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2019-04-03 23:02:46 +0900
committerMichele Calgaro <[email protected]>2019-04-03 23:02:46 +0900
commitfcad8b8d150fb9f508973e3044a103de74ec3877 (patch)
treeca34a8cf3bfbe08335d40c47863b4901e1d19609 /ubuntu/_base/applications/gtk-qt-engine/debian/cdbs/debian-qt-kde.mk
parent5d8ed1fab813d86b04383f7fcf8ab2c994cbea30 (diff)
downloadtde-packaging-fcad8b8d150fb9f508973e3044a103de74ec3877.tar.gz
tde-packaging-fcad8b8d150fb9f508973e3044a103de74ec3877.zip
DEB: use _base folder for a distro instead of specific distros (squeeze and maverick).
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'ubuntu/_base/applications/gtk-qt-engine/debian/cdbs/debian-qt-kde.mk')
-rw-r--r--ubuntu/_base/applications/gtk-qt-engine/debian/cdbs/debian-qt-kde.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/gtk-qt-engine/debian/cdbs/debian-qt-kde.mk b/ubuntu/_base/applications/gtk-qt-engine/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..65f5f6f95
--- /dev/null
+++ b/ubuntu/_base/applications/gtk-qt-engine/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,27 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+
+endif