summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/internet/ktorrent/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2021-07-05 00:28:13 +0900
committerMichele Calgaro <[email protected]>2021-07-05 00:28:13 +0900
commit0cf700f49d6437ea21867ae6300c7056eadfbd97 (patch)
treedec8bff7ef4366370de0ad280d6395c363ce1f3f /ubuntu/_base/applications/internet/ktorrent/debian/rules
parente52d0aefda74071dece63a038079503cdc2cc905 (diff)
downloadtde-packaging-0cf700f49d6437ea21867ae6300c7056eadfbd97.tar.gz
tde-packaging-0cf700f49d6437ea21867ae6300c7056eadfbd97.zip
Rearranged applications folder into sub categories.
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'ubuntu/_base/applications/internet/ktorrent/debian/rules')
-rwxr-xr-xubuntu/_base/applications/internet/ktorrent/debian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/internet/ktorrent/debian/rules b/ubuntu/_base/applications/internet/ktorrent/debian/rules
new file mode 100755
index 000000000..a90794996
--- /dev/null
+++ b/ubuntu/_base/applications/internet/ktorrent/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_INSTALL_MANPAGES_ktorrent = ktorrent.1
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
+
+build/ktorrent-trinity::
+ docbook2x-man debian/ktorrent.1.docbook
+
+clean::
+ rm -f ktorrent.1